Caller can hear me, but can't hear caller


I managed to setup the trunk. And for the inbound route I used the default setting and set one of the extension as the destination. The calls come through but, I can’t hear the caller but the caller can hear me. Where could I have gone wrong. If I setup the SIP account directly on the phone, there is no issue.


Googling “one way audio” will help you understand the most likely cause of the problem.

The short answer is that your firewall is probably not configured correctly.

Thank you for the response,

Please explain why if I remove the SIP account from freepbx and put it directly on the phone I do not have one way audio, but it is still going via the same gateway(Firewall)

I tried turning on and off NAT on the phone but still get the one way audio


There’s too much “how asterisk works” in that question for it to be answered succinctly.

There are lots of places where NAT settings become important. For example, if your PBX is set up behind a NAT firewall and you don’t specify the “gateway” address in the SIP settings, you will get one-way audio. Your phone is probably set up for NAT and is using a server to set your external (routable) address in the headers.

For FreePBX, you’ll need to make sure all of the appropriate ports in the firewall are open and that the UDP ports for RTP are set up to forward incoming (SYN) packets to the server.

It’s all theoretical at this point - if you really want someone to point out the (probably single) error you’ve made, we need more information.

Thanks so much, here is what I have discovered:

Brief Background:

Moved offices and services provider could not provide service in the new office. Got another service provider, who could not offer us a PBX hence why we got freepbx. Now new service provider gave us a new contact telephone number with the SIP account. We asked old provider to forward all calls to the new number so that if someone calls old number it rings on the new number. Did not want to advertise new number, old number on all stationery

Forwarded call are the one with oneway audio on freepbx, but not if SIP account is put on phone. Do I have to create another inbound route for the forwarded calls?

I checked the logs, the one that come through the new number are only 6 pages long but the ones on the forwarded call are almost 30 pages, I think it will be too much to paste here