CallCentric Setup Problems with FreePBX

I recently reinstalled my whole system from the latest PBX in a Flash image. I now wish I had not done so because it has caused so many problems. I think I am getting things back up where they were. However, I can’t seem to get CallCentric setup and working again. I can make outbound calls, but when I call number from a landline not connected to my system, I get Allison saying “The number you have dialed is not in service. Please check the number and try again.”

Can someone please help me with this? At this point I can’t receive any calls…
Thank you SO much for your help in advanced.

Here is some of my Asterisk Log:

[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Executing [[email protected]:1] NoOp(“SIP/callcentric-00000005”, “Received incoming SIP connection from unknown peer to 17772516091”) in new stack
[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Executing [[email protected]:2] Set(“SIP/callcentric-00000005”, “DID=17772516091”) in new stack
[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Executing [[email protected]:3] Goto(“SIP/callcentric-00000005”, “s,1”) in new stack
[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Goto (from-sip-external,s,1)
[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Executing [[email protected]:1] GotoIf(“SIP/callcentric-00000005”, “0?checklang:noanonymous”) in new stack
[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Goto (from-sip-external,s,5)
[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Executing [[email protected]:5] Set(“SIP/callcentric-00000005”, “TIMEOUT(absolute)=15”) in new stack
[2011-05-22 21:20:29] VERBOSE[3116] func_timeout.c: Channel will hangup at 2011-05-22 21:20:44.898 EDT.
[2011-05-22 21:20:29] VERBOSE[3116] pbx.c: – Executing [[email protected]:6] Answer(“SIP/callcentric-00000005”, “”) in new stack
[2011-05-22 21:20:30] VERBOSE[3116] pbx.c: – Executing [[email protected]:7] Wait(“SIP/callcentric-00000005”, “2”) in new stack
[2011-05-22 21:20:32] VERBOSE[3116] pbx.c: – Executing [[email protected]:8] Playback(“SIP/callcentric-00000005”, “ss-noservice”) in new stack
[2011-05-22 21:20:32] VERBOSE[3116] file.c: – <SIP/callcentric-00000005> Playing ‘ss-noservice.gsm’ (language ‘en’)
[2011-05-22 21:20:34] VERBOSE[3117] manager.c: == Manager ‘admin’ logged on from 127.0.0.1
[2011-05-22 21:20:35] WARNING[2897] chan_sip.c: Retransmission timeout reached on transmission [email protected] for seqno 102 (Critical Response) – See doc/sip-retransmit.txt.
Packet timed out after 32000ms with no response
[2011-05-22 21:20:35] VERBOSE[3117] manager.c: == Manager ‘admin’ logged off from 127.0.0.1
[2011-05-22 21:20:37] VERBOSE[3116] pbx.c: == Spawn extension (from-sip-external, s, 8) exited non-zero on ‘SIP/callcentric-00000005’
[2011-05-22 21:20:37] VERBOSE[3116] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/callcentric-00000005”, “”) in new stack
[2011-05-22 21:20:37] VERBOSE[3116] pbx.c: == Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/callcentric-00000005’
[2011-05-22 21:20:41] VERBOSE[3126] manager.c: == Manager ‘admin’ logged on from 127.0.0.1
[2011-05-22 21:20:42] VERBOSE[3128] manager.c: == Manager ‘admin’ logged on from 127.0.0.1
[2011-05-22 21:20:43] VERBOSE[3126] manager.c: == Manager ‘admin’ logged off from 127.0.0.1
[2011-05-22 21:20:44] VERBOSE[3128] manager.c: == Manager ‘admin’ logged off from 127.0.0.1
[2011-05-22 21:20:47] VERBOSE[3136] manager.c: == Manager ‘admin’ logged on from 127.0.0.1

I just changed the “ALLOW_SIP_ANON” setting below to "no"
This made inbound calls ring my phones. However, when I turned Caller ID Superfecta back on and tested an inbound call, it played Allison’s “The number you have dialed is not in service. Please check the number and try again,” again.

Still not sure what I am doing wrong… Thanks you!

; ############################################################################
; Inbound Contexts [from]
; ############################################################################

[from-sip-external]
; Yes. This is really meant to be _. - I know asterisk whines about it, but
; I do know what I’m doing. This is correct.
exten => _.,1,NoOp(Received incoming SIP connection from unknown peer to ${EXTEN})
exten => _.,n,Set(DID=${IF($["${EXTEN:1:2}"=""]?s:${EXTEN})})
exten => _.,n,Goto(s,1)
exten => s,1,GotoIf($["${ALLOW_SIP_ANON}"=“no”]?checklang:noanonymous)
exten => s,n(checklang),GotoIf($["${SIPLANG}"!=""]?setlanguage:from-trunk,${DID},1)
exten => s,n(setlanguage),Set(CHANNEL(language)=${SIPLANG})
exten => s,n,Goto(from-trunk,${DID},1)
exten => s,n(noanonymous),Set(TIMEOUT(absolute)=15)
exten => s,n,Answer
exten => s,n,Wait(2)
exten => s,n,Playback(ss-noservice)
exten => s,n,Playtones(congestion)
exten => s,n,Congestion(5)
exten => h,1,Hangup
exten => i,1,Hangup
exten => t,1,Hangup

How is your trunk and inbound routes setup? Specifically the register string?

Mine is -

1777299xxxx:[email protected]/1777299xxxx

and then I use the 1777299xxxx on the inbound routes.

It’s working fine for me on 2.9 with the following:
Allow SIP Guests = yes (in Asterisk SIP Settings)
Allow Anonymous Inbound SIP Calls = yes (in General Settings)

Do you have an inbound route with 17772516091 as the DID?

Greetings,

I came across your post where you set Allow Anonymous=yes. I’m new to FreePBX, just wondering
wouldn’t this setting make your system insecure? Please explain.

Thank you.