Callback not calling them back

First off, Thank you devs for making FreePBX such a great phone system. I am now running 2 at work and even decided to drop one in at home as a “toy/hobby”.

I am having a small issue with Callback…

Relative info from CLI:

-- Executing [[email protected]:1] Goto("SIP/574538XXXX-00000000", "callback,1,1") in new stack
-- Goto (callback,1,1)
-- Executing [[email protected]:1] Set("SIP/574538XXXX-00000000", "CALL=1574527XXXX") in new stack
-- Executing [[email protected]:2] Set("SIP/574538XXXX-00000000", "DESTINATION=app-blackhole.hangup.1") in new stack
-- Executing [[email protected]:3] Set("SIP/574538XXXX-00000000", "SLEEP=10") in new stack
-- Executing [[email protected]llback:4] System("SIP/574538XXXX-00000000", "/var/lib/asterisk/bin/callback 1574527XXXX app-blackhole.hangup.1 10 &") in new stack
-- Executing [[email protected]:5] Hangup("SIP/574538XXXX-00000000", "") in new stack

== Spawn extension (callback, 1, 5) exited non-zero on ‘SIP/574538XXXX-00000000’

[Note: XXXX added to mask numbers; the actual number appears correctly.]

It appears that the app/script just does not try to callback at all. I have tried 5, 10, and 30 seconds on the call back delay. I was surprised there was no retry or retry delay setting.

Does anyone know if this is broken still or do I need to add something to my setup? I see a bug report --> http://www.freepbx.org/trac/ticket/5492 but has not been touched in over a month.

  • Latest FreePBX 2.10.0 Final with all module updates
  • CentOS v6.2 [2.6.32-220.7.1.el6.i686]

Any help is much appreciated.