Callback Module - Pending Callbacks


I was wondering if there was a place I could go in the FreePBX GUI or host to look at calls backs that are pending from the callback module (not Queue Callback)?



It uses call files. There is no actual tracking.

I trigged a callback that I built in the callback module that calls me back in 3 minutes. It worked; however, at no time did I see anything in /var/spool/asterisk/outgoing using ls. Am I missing something? Thanks for your help!

watch -n 1 ls -l /var/spool/asterisk/outgoing/

will update every second


Thank Dicko,

I ran watch -n 1 ls -l /var/spool/asterisk/outgoing/ prior to dialing the system. I hit the announcement that passes me to the callback module, it worked as expected (got a callback in 3 minutes). At no point did I see anything on my screen other than:

Every 1.0s: ls -l /var/spool/asterisk/outgoing/ Fri Oct 21 06:18:37 2016

total 0

Any other ideas?

The callback was built in the callback module in the GUI and simply points to an announcement for the callback. I forgot to mention in the earlier post that I am on FreePBX / Asterisk Version: 13.7.2

A quick look at


shows that is does not use call-files but sets an "originate " through AMI after pausing x seconds. So try

watch -n 1 “ps axo pid,etimes,cmd |sed ‘s|/usr/bin/php -q /var/lib/asterisk/bin/||’|egrep ‘callbac[k]|PI[D]’”

Thanks for the help dicko, it is really appreciated. When I run he command:

watch -n 1 “ps axo pid,etimes,cmd |sed ‘s|/usr/bin/php -q /var/lib/asterisk/bin/||’|egrep ‘callbac[k]|PI[D]’”

It brings me to an unintelligible view (sample below). Any idea what I am doing wrong here?
********* simple selection ********* ********* selection by list *********
-A all processes -C by command name
-N negate selection -G by real group ID (supports names)
-a all w/ tty except session leaders -U by real user ID (supports names)
-d all except session leaders -g by session OR by effective group name
-e all processes -p by process ID
T all processes on this terminal -s processes in the sessions given
a all w/ tty, including other users -t by tty
g OBSOLETE – DO NOT USE -u by effective user ID (supports names)
r only running processes U processes for specified users
x processes w/o controlling ttys t by tty
*********** output format ********** *********** long options ***********
-o,o user-defined -f full --Group --User --pid --cols --ppid
-j,j job control s signal --group --user --sid --rows --info
-O,O preloaded -o v virtual memory --cumulative --format --deselect
-l,l long u user-oriented --sort --tty --forest --version
-F extra full X registers --heading --no-heading --context
********* misc options *********
-V,V show version L list format codes f ASCII art forest
-m,m,-L,-T,H threads S children in sum -y change -l format
-M,Z security data c true command name -c scheduling class

Thanks again!

That might be a ps version problem on your OS

start with

ps -aux|grep callback

the rest is formatting

Got it, again thanks to dicko! I missed a part of the error in the paste of my previous post.

“ERROR: Unknown user-defined format specifier “etimes”.”

“It seems that only newer versions (>=3.3.0) of procps (actually procps-ng) have the “etimes” field.” (Google search)

The following command worked:

watch -n 1 “ps axo pid,lstart,cmd |sed ‘s|/usr/bin/php -q /var/lib/asterisk/bin/||’|egrep ‘callbac[k]|PI[D]’”


1512 /bin/bash /var/www/html/admin/modules/vqplus/
1514 /usr/bin/php -q /var/www/html/admin/modules/vqplus/queue-callback.php
5274 php /var/lib/asterisk/bin/callback ############# app-announcement-66.s.1 180

for older versions of ps you SHOULD be able to use etime (no s) it will display in hr:mn:sc the elapsed

You might need to “tune out” the queuecallback stuff, and leave out the sed ‘s|/usr/bin/php -q /var/lib/asterisk/bin/||’ pipe


watch -n 1 “ps axo pid,etime,cmd|grep -v queue|egrep ‘callbac[k]|PI[D]’”

1 Like

That’s even better! Thanks!