Call via internal trunk wont route internally

Hi all,

I have a 2 pbx setup, one with freepbx 13.0.74 and the other is an old elastix 2.4 setup. Each pbx has 2 sip trunks, one for internal call between the 2 offices and one for external telco calls. the internal calls from freepbx to elastix will not route out via the internal trunk. I have the internal trunk route as first preference on both pbx’s and have not set up a failover trunk for internal calls, yet when i try calling and internal extension from the freepbx it is pushed out via the external trunk. From the elastix pbx calling internally works fine via the internal trunk - is their a trick i am missing here please?



Have you read thoroughly

Oops, i misread, you are using siip.

What context is the tie trunk in on either end?

Hi Dicko,

I have tried context default, from-internal and from-trunk, what is happening is the route goes straight to the external trunk without even first trying the internal trunk and so there is no error / failure message. I have the internal route above the external route but it seems freepbx does not even see the route.



current trunk settings:


Assuming the trunk is connecting, what does your outbound route look like?

What number rules do you have specified for the trunks?

What do the logs say about the call? Are you actually falling through the local trunk and failing, or are you not hitting it at all?

You haven’t supplied enough information for anyone to actually help you.

Hi Dave,

If you check my original post you will see i mentioned the trunk works from the elastix pbx to the freepbx fine, in the opposite direction however it goes straight to the external trunk without a failure message and despite the fact that i do not have the external trunk in the outbound route for internal calls.

The number rules are as follows, i have the same setup on a few elastix boxes working fine, this is the first time i have tried it with the latest version of freepbx though:

I think “30[0-9]” should be “30X”.