Call to undefined function core_users_list()

I upgraded to from -1 and now when I hit apply, I get this error:

Everything was fine prior to beginning the upgrade process, except I was getting an error about needing to upgrade PHP. I followed the upgrade steps on this page:

But now it won’t reload. Any ideas?

What version were you on before the upgrade? It was not or you would of been on the php 5.3 already. PHP 5.2 was used on much older versions of the Distro so it sounds like you missed a ton of upgrades and just installed the latest where you need to run them in order based on what version you had before using the upgrade scripts.

I had upgraded to the latest that I could using the module admin. I checked, using the directions on the page I linked, and am pretty sure I didn’t skip anything. What can I do at this point?

Do I need to install from scratch, or is there another solution?

I’m having exactly the same problem after an upgrade, I ran each of the upgrade scripts sequentially and I have php 5.3

exit: 255
found language dir fr for directory, not installed on system, skipping
PHP Fatal error: Call to undefined function core_users_list() in /var/www/html/admin/libraries/extensions.class.php on line 0

1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

I had a quick search in /var/www/html/admin/libraries/extensions.class.php and I can’t even find a function called core_users_list it appears to be missing completely… Although i’m not very good at php so i might just have missed it, don’t think I did though.

Yeah, I needed this running, so I just reinstalled. Would be nice to have a solution, though.

Can you verify that the core module is enabled and installed?

Also can you verify if you have End Point Manager installed or not?

End point manager is installed

However I tried removing via module admin but it didn’t help nor did reinstalling

I’ll check the core and report back

For the record, I also uninstalled EPM with no change. Reinstalling did nothing, as well. Core was not installed (or at least did not show up in the module admin).

That is your issue. Core seems to be done. It would appear the module got disabled.

Try a sudo -u asterisk var/lib/asterisk/bin/module_admin install core and see if that reinstalls core.

If someone wants to PM me SSH access to a system that is doing this I can track down the issue. I have tried this 3 times today upgrading systems and it never gives me this issue.

sudo -u asterisk /var/lib/asterisk/bin/module_admin install core
The following error(s) occured:

  • Cannot find module

Seems the core module has gone awol

do a

sudo -u asterisk /var/lib/asterisk/bin/module_admin download core


sudo -u asterisk /var/lib/asterisk/bin/module_admin install core

Hi Tony

That seems to have fixed it thanks.

Did you have any other 3rd party modules enabled before the upgrade. I am really trying to figure out why this is happening as I do not want it to keep happening for people.

The one box I got to look at has Caller ID Superfecta installed?

I had no 3rd party modules, aside from EPM installed.

If anyone else is having this issue it appears to be a issue with a missing package from much earlier version of the Distro.

Do a

yum install php-process

and than you should be able to install core and all the other modules. I have put checks in the 4 latest upgrade scripts for this for any new users running the upgrade scripts

Thanks for the work on this, tony. Much more confident updating now.