Call screening announcement switches to English instead of default language (Dutch)


(Wesx) #1

Hi all,

in a previous topic I almost got working what I need from FreePBX, I wanted call screening only for anonymous callers. I was greatly assisted back then but the topic got expired and I still haven’t resolved this problem.
The short version is that all Dutch sound files are installed, Dutch is the default language and Dutch announcements are played except …
when call screening is active the caller hears a Dutch announcement but the callee hears an English announcement.

Here’s the long version:

  • Installed the follow me module.
  • Added a custom extension 4593, initial ringtimeout 0, ringstrategy ringallv2, ringtime 20, follow-me list 1000 and 4013, destination no answer voicemail 4013 (unavail) and call screening with no-memory
  • Changed the inbound route for the test DID and added “_0XXXXXXXXX” to CID as pattern and as destination ringgroup 4003 containing 1000 and 4013
  • Added an inbound route with the same DID but empty CID and as destination the custom extension 4593

WORKS Calling from a national number with proper CLIP matches the pattern in the first inbound route and ringgroup 4003 starts ringing , upon noanswer the VM menu is in Dutch/NL.

ALMOST WORKS Calling from a hidded number matches the second inbound route (with empty CID field) and goes to custom extension 4593. Now the announcement is played (because of the call screening) in Dutch/NL as expected. Next the follow me members are ringed. When a member answer the menu is played in English/EN???

The freepbx default language is dutch, all dutch sound files (in all formats) are present with the same permissions.

Here’s a snippet from the asterisk log:
2019-09-24 10:11:53] VERBOSE[23941][C-00000136] bridge_channel.c: Channel Local/FMGL-1000-4013@from-internal-00000038;2 joined ‘simple_bridge’ basic-bridge <299be7e0-8fe7-487e-8608-00f1d695f076>
[2019-09-24 10:11:53] VERBOSE[23935][C-00000136] file.c: <Local/FMGL-1000-4013@from-internal-00000038;1> Playing ‘priv-callpending.alaw’ (language ‘en’)
[2019-09-24 10:11:57] VERBOSE[23935][C-00000136] file.c: <Local/FMGL-1000-4013@from-internal-00000038;1> Playing ‘priv-callerintros/anonymous.slin’ (language ‘en’)
[2019-09-24 10:11:58] VERBOSE[23935][C-00000136] file.c: <Local/FMGL-1000-4013@from-internal-00000038;1> Playing ‘screen-callee-options.alaw’ (language ‘en’)
[2019-09-24 10:12:07] VERBOSE[23935][C-00000136] pbx.c: Executing [s@macro-auto-blkvm:1] Set(“Local/FMGL-1000-4013@from-internal-00000038;1”, “__MACRO_RESULT=”) in new stack

I’ve searched the log for anything language related but couldn’t find anything useful apart from that the initial language was Dutch/NL

I searched online and found this language for incoming anonymous sip but didn’t mess with any config files before you told me to do so. Also the problem doesn’t occur when initially answering the anonymous sip call.

When in the asterisk cli and I’ve picked up the call and listen to the 4 options IVR call screening menu (in English) and run show channels, there are 3 active. Two of them named Local/FMGL-1000-1001-4013@from-internal-00000040;[1 and 2] show “Language: en” The other channel is in dutch.

If I add exten => s,n,Set(CHANNEL(language)=nl_NL) as second line to the [macro-dial] section in extensions_additional.conf and do a dialplan reload the messages are again played in Dutch.

Question is how do I set the language correctly?

Again thank you all for your time and help.


#2

Do you have

defaultlanguage = NL

in /etc/asterisk/asterisk.conf [options] ?


(Wesx) #3

@dicko, thank you for your input.

No I don’t have that line in /etc/asterisk/asterisk.conf. The only obvious reference to language is the languageprefix=1 in the options section. But I don’t know what it does, I need to look that up.
This is a brand new installation and I haven’t done any customization apart from adding some extension, a trunk and the call screening.
If I add “defaultlanguage = NL” to the /etc/asterisk/asterisk.conf , does the config file get over written every time I press apply config? And what do I need to do to let asterisk and freepbx pick this up.

Thanks


#4

No, /etc/asterisk/asterisk.conf is hands-off for FreePBX reload, defaultlanguage sets asterisk’s GLOBAL language, you are having trouble with LOCAL channels, hopefully setting the GLOBAL will fix that.


(Wesx) #5

I made the change and did a rasterisk -x “core reload” but the announcement is still in English. Should I run a different command to let asterisk pick up this change?


#6

At your convenience I would do a full asterisk restart.


(Wesx) #7

@dicko, sorry but no cigar. In one of your links the language module was mentioned, which I just installed. I tried forcing the language to Dutch at various places, inbound route, the special extension with the follow me and the extension which answers the call. Yes if I force the language in the inbound route to english the IVR menu switches from dutch to english. But the language remains English when an extension answers. Oh and I rebooted the system just to be safe with the defaultlanguage=NL setting in asterisk.conf

Any other suggestions?


#8

Sorry, nothing else from me, luckily my defaultlanguage=en_US :slight_smile:


(Wesx) #9

@dicko, your initial suggestion was completely right, only the syntax wasn’t.
After some sleep and a bit more searching I found other posts regarding the defaultlanguage setting. If you want dutch you need to enter “nl” (all lower case) not “NL” like you suggested in your post. Now it works.

Could you help me determine whether this is a bug or not? From an end user perspective it is. You install freepbx, install the Dutch sound files and configure the default language as Dutch in the dashboard. Everything is now in Dutch, VM menu’s etc except this call screening config switches to English.
I don’t think that for such a simple feature like call screening the end user should edit /etc/asterisk/asterisk.conf. That’s the whole point of freepbx, in general no config editing just clicking.

Again many thanks.

@Stewart1 , problem solved


#10

IMO, this is a bug worth reporting. When you set the default language in the GUI, all necessary configuration files should be automatically set. There is no reason for English to be king. “If you’re not Dutch, you’re not much.”


(Dave Burgess) #11

Here, here. :slight_smile:

Just kidding. I have Dutch friends.


#12

Actually, the koninglijke nature of en is hardcoded in many places throughout the asterisk source code. :slight_smile: it’s where you will ultimately end up if a file is unavailable for any reason.