Call recording On demmand

Hi everyone,
We have set “always” (record incoming and outgoing calls) on extension 300, and “on demmand” (incoming and outgoing calls)on extension 301.
When we make a call to an outside number or it get a call from an outside number it records the call.
When extensions 300 get a call from extension 301 the call it’s also recorded, but, when 300 calls to 301 that call is not recorded.
It’s possible to record thats calls having “on demmand” set on extension 301.
We don’t need any other records on ext 301, except calls from ext 300
I attach part of cli output.

-- Executing [[email protected]:6] Set("SIP/300-b63b36b0", "CFBEXT=") in new stack -- Executing [[email protected]:7] Set("SIP/300-b63b36b0", "RT=50") in new stack -- Executing [[email protected]:8] Macro("SIP/300-b63b36b0", "record-enable|301|IN") in new stack -- Executing [[email protected]:1] GotoIf("SIP/300-b63b36b0", "1?check") in new stack -- Goto (macro-record-enable,s,4) -- Executing [[email protected]:4] AGI("SIP/300-b63b36b0", "recordingcheck|20100421-115131|1271843491.43436") in new stack -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck recordingcheck|20100421-115131|1271843491.43436: Inbound recording not enabled -- AGI Script recordingcheck completed, returning 0 -- Executing [[email protected]:5] MacroExit("SIP/300-b63b36b0", "") in new stack -- Executing [[email protected]:9] Macro("SIP/300-b63b36b0", "dial|50|TWtwr|301") in new stack -- Executing [[email protected]:1] GotoIf("SIP/300-b63b36b0", "1?dial") in new stack

Sorry for my english,
Regards / Salut!

We solved this problem adding next code in correspondent context on our extensions_custom.conf file.

exten => _XXX,1,Set(CALLFILENAME=${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)}-${UNIQUEID}) exten => _XXX,n(record),MixMonitor(${MIXMON_DIR}${CALLFILENAME}.${MIXMON_FORMAT},,${MIXMON_POST}) exten => _XXX,n,Goto(from-internal,${EXTEN},1)

Maybe this can help someone.

Regards/Salut!

I have the same issue, and would like more details on how you fixed. i have examined our extensions_custom.conf but do not understand where you placed the provided code…

Thanks in advance!