Call recording macro and postrecording script


I have one Ubuntu server running asterisk + freepbx, the system was downloaded and compiled and I was using asterisk 1.4 and FreePBX 2.6 (I guess, can’t remember correctly now). This box is installed on a production environment and it was working fine so far.

One of the most important part on this setup is we have the need of record ALL calls no exceptions, the files need to complain with an specific file naming that starts with a fixed string, then it follows by the timestamp with hour, minutes and seconds the call was started, after a string to identify if it is an incoming or outgoing and the id for the extensions and numbers when involving pstn, all this was handled by a macro called ‘macro-record-enable’ defined on the file /etc/asterisk/extensions_override_freepbx.conf. Once the call is saved using a WAV format a postrecording script was triggered to resample the file and convert it to mp3 that was stored on a specific location on the backup hard drive.

That was running all fine and dandy till last week when the system was updated to Asterisk version 1.8 (certified-asterisk-1.8.11-cert2) and FreePBX 2.10, to update Asterisk the sources were downloaded and compiled (compiling also asterisk-addons), FreePBX was updated using its own module to update itself.

Everything was compiled and updated and the system runs fine as before however the recordings are giving me some trouble, the postrecording script isn’t being triggered anymore, I couldn’t even find on FreePBX web interface the module page to control this variable, the recordings aren’t being handled by the macro-record-enable anymore, seems they are being handled by a macro called ‘sub-record-check’ defined on extension_additional.conf. Despite the fact this new macro could be edited in order to reflect our needs, this solutions wouldn’t work as the hole file is regenerated by FreePBX each reload, I even tried to replicate this macro in order to reflect our needs on the file /etc/asterisk/extension_custom.conf that was empty but it didn’t work, the recordings were still generated with the default naming and location and the script wasn’t called at all.

My question then is how should I proceed in order to accomplish the same setup I had before the update. Is the macro-record-enable deprecated? Which file can I edit without loosing its content on each FreePBX restart to redefine the macro that is supposed to be triggered by the system recording where I can set up our convention for file name and path and start the postrecording after the WAV file is generated?

Sorry for the long post, I hope I have covered all information that is relevant to my current versions/setups.

Thanks in advance