Call Recording - Beep

We are running FreePBX: 10.12.0

All is working well, except one issue. When we press *1 for On Demand Call Recording, we do not hear a “beep” for the call. We’ve moved this specific site from an Elastix distribution and finding the setting for this feature to “Beep” has not yet been successful


into the file: features_general_custom.conf

However, I should point out this parameter (courtesytone=beep) was already in: features_general_additional.conf

No luck with this change.

Please provide any feedback or assistance on where this setting may be adjusted in the GUI, and/or through files in the CLI.



FreePBX uses it own call recording functions and the beep is default for on-demand as long as you are on 2.10 or newer.

Thanks Tony.

We’re on FreePBX ver Asterisk ver 10.12.0

As we set up this distribution for this site, it is possible we may have somehow changed the default so beep is now disabled, but we don’t have any recollection of making that change.

This is a fresh rebuild and all extensions, ring groups, and IVRs were rebuilt during the upgrade process. (We didn’t attempt a backup/restore from the old Elastix distribution.)

Is there a location we can check or change this setting? Are we potentially not using this FreePBX feature correctly? Recording is working, and the file is being saved. We just aren’t getting the beep.



Hello, I also have a new freepbx distro install and Asterisk 10. I don’t get a beep when I press *1. It is recording, but without the feedback of the beep my users aren’t happy like the old system we were on (old trixbox).
The extensions are set On Demand Recording enabled.

I’m glad I’m not the only one with this problem, and would love it if someone had a fix!