Call recording, access denied?

Did both, restarted the server as well, still receiving “access denied”. This is extremely odd.

Yes it is as you have everything set up properly based on what you’re telling me. Are you using the official distro? Maybe open a full fledged support ticket.

Also is your system fully up to date?

Okay so heres the interesting part, I just attempted calling out of another extension and it worked. It seemed that it doesnt work for the main extension. Could it be that the main extension is being used on a couple of phones? While the extension I just tried is unique to this phone

Could very well be it’s definitely odd behavior. How many phones do you have the main extension pointing to?

4 right now. I believe it might be that. What I can do is create another 4 extensions that replicate the main line and test that out

I was about to suggest the same and if it works out then to set up a ring group so all 4 still ring as you seem to want.

Okay I will go ahead and do this. Give me a few minutes to set up the extensions and ring group

Actually never mind, I checked and every phone has their personal line. The only thing in common is that they share the voicemail

So what I believe the issue this entire time was that I completely overlooked the fact that each line had their own extension and I never enabled it on their account. Only the main line which serves as the unified voicemail. Let me check that out.

If I am correct, all 4 lines will have to have login/pass to the UCP to access the recordings correct?

Share the voicemail how?
Are all programmed in the extension under Mailbox to the same [email protected]?
Do you mean they all have access using *98 and entering the mailbox/pin?

Yes correct. [email protected], all 4 extensions have that under their mailbox. Have a speed dial on the phones to access it.

I would try from a shell

rasterisk -x ‘database show’|grep 1549

I think there is something in your astdb

I successfully got it to work now lol I overlooked the simplest fact…I apologize about spending some of your time. Now, to access the recordings, each extension must have access to the UCP correct?

Is there an easier way to access them through the FreePBX GUI without having to buy the other module?

Hi Dicko,

I got it to work! Thank you for replying though :slight_smile:

UCP doesn’t cost anything or are you referencing another module?

All you should need to do is create a user in User Management tied to the particular extension and then assign the appropriate permissions.

Yes, the call recording module that allows you to view the recordings directly from the FreePBX Gui.

Similar to this: https://www.freepbx.org/call-recording-reports/

Is there any way to view the recordings through PBX, without having to log in through the UCP?

I’d say possibly the CDR Report as that’s how we review on our system. Not too sure you want end users having access to that kind of items though.

Thank you, thats exactly what I was looking for. James, you’ve been absolutely great. I owe you

You’re very welcome. Glad we were able to sort it out in the end. :slight_smile: