Call park: Can't transfer calls to parking lot

I have a newly created FreePBX install on a Raspberry Pi 4 (RasPBX). Everything working fine including normal call transfers, except call parking using the standard Parking module.

I’ve set up extension 300 as the parking lot extension, and slots 301-305 for parking. When I do an attended transfer of a call to 300 (or if I simply dial 300), I get a message that “The call cannot be completed as dialed”. If I do a blind transfer to 300, the call simply drops. If I try to transfer a call directly into one of the slots 301-305, it says that there is no parked call there.

Any ideas what could be wrong? I’m completely new to FreePBX, but nonetheless I have my first system running perfectly after a few days of setup and fine-tuning. Just need to get the parking working.


Provide a call trace via Pastebin:

Since you don’t have a distro install, there could be a number of problems. Post the logs as asked.

There should be no issues with basic parking like that. There is an issue with park calls returning on timeout that I was trying to debug last night.

I don’t know what’s wrong with your 300, but a blind transfer to 301 will probably work correctly. For testing, note that you can park an internal or an external call, but you cannot park internal functions such as voicemail, speaking clock, echo test, etc.

On a small system, you probably need no more than one parking space. Program a BLF key on each phone as ‘Call Park’ with a value of 301. It should normally be green. When on a call, press the button and it will park the call and turn red. At another extension, press the red button, which will retrieve the call and turn green. No one will need to know the feature code for parking.


I tried the following test call in order to create a call trace:

  • 104 calls 102
  • 102 blind-transfers to 300 (the parking lot extension)
    Result: The call simply drops instead of going into the parking lot.

Just to make sure call transfers work as expected, I tried blind-transferring the call to *43 (the built-in echo test) and that works fine.

Here is a pastebin call trace as requested:

It’s as if extension 300 doesn’t exist. When I dial it directly (which should self-park the call according to the documentation), I just get a “Your call cannot be completed as dialed” message. This is the same message I get when I try to call any non-existent extension.

Transferring to 301 doesn’t work either.

I’ve also attached a screen shot of my Parking module configuration. Do I have to reboot after installing it? I did not do that.

Thanks for helping!

Just to update the thread, I got this working. Turns out my rasPBX box just needed a reboot. I had assumed (apparently incorrectly) that FreePBX would warn me if a reboot is needed after a configuration change. I guess not!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.