Call Logging Question (Not Recording)


I am new to FreePBX and still learning its functionality and I see that there is a report function. My install does not seem to be logging the calls made (I am not recording calls). Is there something I need to do to enale logging?



After doing all of the above I still cant install. I dont know how to cut and paste the error from the Java shell onto here so I can only offer a few lines of the rror messages…

chan_ooh323.c:3144: error a AST_CAUSE_NORMAL undeclared (first use in this function)
make [1]: ***[chan_ooh323.c]error1

does this example mean anything?


I upgraded asterisk to v1.8 and included all of the addons in the install. It works now.

Thanks for all of the help.

Thanks for that.

I will report back


The server isnt operational yet so downtime should be ok.

I did d/l something called gcc (which I think is a c compiler), but I think your advice is valuable as there is no such thing as too much prep.

I will try this tonight.


gcc is a good start, and you are right that it is a compiler. But there are a few more things that the system uses to compile things. An example is the source code for your kernel. There are also various parsing tools and other things that the groupinstall will bring in. A really bad analogy would be this is like installing the .NET stuff and other .dlls on your Windows box before you can use Visual Studio.

This is my current build dependency yum list:

[code]yum -y install subversion mlocate openssl openssl-devel perl perl-Net-SSLeay perl-Crypt-SSLeay libtermcap-devel ncurses-devel doxygen curl-devel newt-devel mod_ssl crontabs vixie-cron speex speex-devel unixODBC unixODBC-devel libtool-ltdl libtool-ltdl-devel mysql-connector-odbc mysql mysql-devel php php-cli php-common php-gd php-pdo php-mbstring php-mcrypt flex screen mod_ssl mysql mysql-devel mysql-server build-essential libxml2 libxml2-devgcc gcc-c++ wget bison php-mysql php-pear php-pear-DB php-mbstring make ncurses-devel libtiff-devel php-gd audiofile-devel gtk2-devel


This uses somewhat of a “kitchen sink” approach, however it will install everything one needs to build Asterisk and most add on packages.

If you have not compiled anything on the system before, then you need to install the compiling tools. The easy way will get you a few extra packages that you don’t need, but it’s easy. Just type in yum groupinstall "Development Tools" at the command prompt. It will download and install a bunch of packages to your system and get everything set up for compiling source code. That is probably what your errors are telling you.

You should also let us know exactly what the errors are saying. They can help us track down the problem.

Finally, don’t worry. I had this exact problem last week and fixed it by compiling the same package. There is an update in the repos for asterisk16-addons-mysql right now that might fix the problem. Of course, it came in the day after I compiled it myself.

Before you do all of this compiling and stuff, you might want to do a yum update to get everything up to the latest version. If you haven’t done this yet, there have been a few changes since the ISO was created that will require a reboot. Be sure to schedule some downtime for this.

I have done some reading and it appears I need to install asterisk-addons- however as I am new to asterisk (as well as Linux) I don’t know how to install this.

So far I have.
switched to usr/src folder
used wget to get asterisk-addons- from asterisk website
used tar to uncompress the addons
used ./configure - not sure why but it seemed to work.

now here is where I go wrong…

I used ‘make’ to prepare an install - but see errors here.
I have also tried ‘make install’ after this, but this does not work either.

Has anyone installed this addon before and is there a process I could follow as a newbie?




It doesnot look to me like its loaded. This is after restarting amportal.

Th modules listed were

Do I need to load anything?


Am I correct in assuming that If I had call logging working correctly I would see a list of calls on the reports tab in the browser?

I still dont seem to be getting this?



You might need to do an amportal restart. Then you can check to see if it has loaded correctly. Go to the Asterisk CLI and type in module show like cdr. You should see an entry MySQL CDR Backend.

You just need to install the addons package that is appropriate for your system. Assuming your asterisk version is 1.6, just type in:

Change to asterisk14- or asterisk18- if that is appropriate for your system.


Will try this tonight.



The functionality you mentioned would utilize the “announcements” module.

Do you have the asterisk mysql logging module enabled? mysql properly setup?

This is very odd, the (relevant) thread I posted this to is gone and the message is now in a different thread.

Very odd (or I am cracking up)

well thanks for your help anyway…although I am still confused as to how to see my call log.