Call logging has stopped (CDR not working)

Apologies but I am fairly new to Linux stuff so would appreciate a few pointers.

My Call logging stopped earlier this week after applying a patch to get UK CLI working on my Digium X100 card. CLI now works but CDR doesnt! (Followed the instructions on the Novavox site

Now looking back at it I suspect as part of those instructions the problem came with the line rm -rf /usr/lib/asterisk/modules

Somehow or another I didnt manage to reinstall the adds on properly (although I think I have done that since)

My cdr_mysql.conf file looks like this:-

; Note - if the database server is hosted on the same machine as the
; asterisk server, you can achieve a local Unix socket connection by
; setting hostname = localhost
; port and sock are both optional parameters. If hostname is specified
; and is not “localhost”, then cdr_mysql will attempt to connect to the
; port specified or use the default port. If hostname is not specified
; or if hostname is “localhost”, then cdr_mysql will attempt to connect
; to the socket file specified by sock or otherwise use the default socket
; file.

and alsp

trixbox1*CLI> cdr status
CDR logging: enabled
CDR mode: simple
CDR output unanswered calls: no

So looks like this might be the problem?

I have tried logging into the mysql database and appear to have been successful using the amp109 password.

So what now??

Be grateful if you could quote me command lines as ‘re-install addons’ isnt quite enough (although I am learning!)

Any help gratefully received!


Kernel Version 2.6.18-53.1.4.el5 (SMP)
Distro Name CentOS release 5.2 (Final)
Freepbx 2.4.0
Trixbox v2.6.1.10


I have tried the following and restarted the box but with no joy…

#cd /usr/src


tar -zxvf asterisk-addons-1.4.7.tar.gz

cd asterisk-addons-1.4.7

make clean


make install

I’m not sure about how to go about fixing this exactly but the line "rm -rf /usr/lib/asterisk/modules " has caused many other issues. 1. it removed all compiled modules that asterisk needs to function. It’s more then just the CDR. zap, zip, iax, all the codecs, etc.

They have you removing all pre-compiled modules for the Trixbox build you have and then having you attempt to re-build them all manually. In that trixbox is known for releasing changes without notice trying to keep in sync and functional will be a issue from now on.

In that you purchased from them there is a statement way at the top “Novavox customers only: If after following the guidance provided on the support page you are unable to resolve the issue then please contact us at [email protected].” I’d take them up on it as you no longer have a standard trixbox install which makes downloading patches for trixbox going forward almost impossible as those will overwrite your compiled ones and break things again. so it will be a race to keep current.

As a side note are working with trixbox 2.6.1 which is a forked version of FreePBX. This means that Fonality took a copy of the FreePBX code and made changes to it, then has not yet provided those changes back to the development team so nobody really knows what is going on with that code any more (totaly separate issue from yours currently).

Thanks for that - sounds like it is export my back up settings and rebuild from scratch and re-import the settings using Restore (once I have FTPed them back to the box) to get me back to where I was pre my CLI upgrade (at least I did a snapshot pre CLI upgrade).

Given that my main and only reason for using the Novavox instructions was to get UK CLI working on my X100 (which it DID achieve I have to admit) are there any better instructions for getting UK CLI working once I do my rebuild??

Is this a better option applying this patch?


I’ve never used any of the Novabox cards so can’t speak about it. But I’d first off contact them and ask why you are having this issue and how to fix it. It might be something simple.