Call from internal extension to inbound routes rings busy

When we call an inbound route DID from an internal extension
it always rings busy.

I know that inbound routes expect only external calls. I also know that calls from extension to extension should use the internal extension number (e.g. 401) not the outside DID and that I can create a loopback outbound route to catch these type of calls.

However, there should be an easier solution to this. I don’t get why inbound routes have to reject calls from an internal extension. Is there no setting that would allow me to change that so calls to inbound routes are accepted even if they are coming from an internal extension?

Inbound Routes only apply to calls that come in from trunks.

If you dial a DID, any DID, from an extension, it is going to look for an outbound route to determine where to send the call. If you don’t have a outbound route that tells FreePBX/Asterisk where to send the call, the call will fail.

If you want your users to be able to dial your DID internally, you might want to create a Ring Group whose # is the same as the DID. The Ring Group would route the calls locally.

There are also other, much more complicated ways to do it here:

and here: