Call Forwarding Help!

Hello

I am running Freepbx 2.11.0.12, Asterisk 1.8.9.3, PBX Firmware: 1.89.210.57-2, PBX Service Pack: 1.0.0.0

I have the system connected via an E1 link to an Alcatel 4400 where most of our users are. Up until last week I have had cisco routers taking the link across a large site. All was well. I have now invested in an E1/Fibre unit that boosts it over fibre doing away with the cisco routers (and a huge amount of config!)

The problem I am having now (since taking the cisco routers out of the loop) is call forwarding.

Example:

3 extensions. One IP and Two on the Alcatel system.

IP - 3001
Alcatel Line 1 - 7909
Alcatel Line 2 - 7906

Basically, If there is a forward set on any of the Alcatel phones the call fails with a message from Asterisk saying the number is not in service. Trace below showing a call from 3001 to 7909 that is on an immediate forward to 7906.

This works fine with the cisco routers in situ as they must have blocked something but not sure what.

Can anyone advise?

Many Thanks

[2014-02-19 09:30:26] DEBUG[10831]: sig_pri.c:985 sig_pri_request: sig_pri_request 1
[2014-02-19 09:30:26] DEBUG[10831]: sig_pri.c:6498 sig_pri_call: CALLER NAME: TEST NUM: 3001
– Requested transfer capability: 0x00 - SPEECH
– Called DAHDI/g0/7909
– DAHDI/i1/7909-5df is proceeding passing it to SIP/3001-0000064b
– Span 1: DAHDI/i1/7909-5df is CallRerouting/CallDeflection to ‘7906’.
– Now forwarding SIP/3001-0000064b to ‘Local/[email protected]’ (thanks to DAHDI/i1/7909-5df)
[2014-02-19 09:30:26] NOTICE[10831]: app_dial.c:883 do_forward: Not accepting call completion offers from call-forward recipient Local/[email protected];1
[2014-02-19 09:30:26] NOTICE[10831]: app_dial.c:883 do_forward: Not accepting call completion offers from call-forward recipient Local/[email protected];1
– Hungup ‘DAHDI/i1/7909-5df’
– Executing [[email protected]:1] Set(“Local/[email protected];2”, “DID=7906”) in new stack
– Executing [[email protected]:2] Goto(“Local/[email protected];2”, “s,1”) in new stack
– Goto (from-zaptel,s,1)
– Executing [[email protected]:1] NoOp(“Local/[email protected];2”, “Entering from-dahdi with DID == 7906”) in new stack
– Executing [[email protected]:2] Ringing(“Local/[email protected];2”, “”) in new stack
– Local/[email protected];1 is ringing
– Executing [[email protected]:3] Set(“Local/[email protected];2”, “DID=7906”) in new stack
– Executing [[email protected]:4] NoOp(“Local/[email protected];2”, “DID is now 7906”) in new stack
– Executing [[email protected]:5] GotoIf(“Local/[email protected];2”, “0?dahdiok:checkzap”) in new stack
– Goto (from-zaptel,s,6)
– Executing [[email protected]:6] GotoIf(“Local/[email protected];2”, “0?zapok:neither”) in new stack
– Goto (from-zaptel,s,7)
– Executing [[email protected]:7] Goto(“Local/[email protected];2”, “from-pstn,7906,1”) in new stack
– Goto (from-pstn,7906,1)
– Executing [[email protected]:1] Set(“Local/[email protected];2”, “__FROM_DID=7906”) in new stack
– Executing [[email protected]:2] NoOp(“Local/[email protected];2”, “Received an unknown call with DID set to 7906”) in new stack
– Executing [[email protected]:3] Goto(“Local/[email protected];2”, “s,a2”) in new stack
– Goto (from-pstn,s,2)
– Executing [[email protected]:2] Answer(“Local/[email protected];2”, “”) in new stack
– Local/[email protected];1 answered SIP/3001-0000064b
– Executing [[email protected]:3] Wait(“Local/[email protected];2”, “2”) in new stack
– Executing [[email protected]:4] Playback(“Local/[email protected];2”, “ss-noservice”) in new stack
– <Local/[email protected];2> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Executing [[email protected]:1] Macro(“SIP/3001-0000064b”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/3001-0000064b”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/3001-0000064b”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“SIP/3001-0000064b”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/3001-0000064b’ in macro ‘hangupcall’
== Spawn extension (macro-dialout-trunk, h, 1) exited non-zero on ‘SIP/3001-0000064b’
== Spawn extension (macro-dialout-trunk, s, 22) exited non-zero on ‘SIP/3001-0000064b’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 7909, 5) exited non-zero on ‘SIP/3001-0000064b’
== Spawn extension (from-pstn, s, 4) exited non-zero on ‘Local/[email protected];2’
– Executing [[email protected]:1] Macro(“Local/[email protected];2”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“Local/[email protected];2”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“Local/[email protected];2”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“Local/[email protected];2”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘Local/[email protected];2’ in macro ‘hangupcall’
== Spawn extension (from-pstn, h, 1) exited non-zero on ‘Local/[email protected];2’

I thought I had fixed this by changing the context of the link between Asterisk and Alcatel from from-zaptel to from-internal however now I’ve found that people who have forwarded Alcatel phones to a voicemail box (which we use to make use of the email facility) has their call dropped. Looking at the trace it plays the wav for a fraction of a sec then hangs up for no reason.

I’ve changed it back and everything it working but I’m now back to my original issue:

-- Span 1: DAHDI/i1/7909-724 is CallRerouting/CallDeflection to '7984'.
-- Now forwarding SIP/3001-00000703 to 'Local/[email protected]' (thanks to DAHDI/i1/7909-724)

[2014-02-24 10:11:38] NOTICE[14872]: app_dial.c:883 do_forward: Not accepting call completion offers from call-forward recipient Local/[email protected];1
[2014-02-24 10:11:38] NOTICE[14872]: app_dial.c:883 do_forward: Not accepting call completion offers from call-forward recipient Local/[email protected];1
I believe the issue here being that it is trying to route within itself, not finding the number and giving a no service message?

I’m totally stuck now! - Help please?

Turn off p-asserted identity and trust-rpid on the link

Hi Skyking

I have trust-rpid set to yes and sendrpid set to Send Remote-party-ID header against each extension and both also enabled within Advanced Settings > Device Settings

Is this what I need to change as I’m not aware of any other section that I can set this, especially per link?

This is a QSig E1 trunk not a SIP trunk, does the same still apply?

Turn it off on the trunk. You don’t need to disable system wide.

For syntax on trunk variables refer to Asterisk sample sip.conf that is distributed with each Asterisk version package.

So it is, so you are trying to redirect via the PRI and your provider won’t accept that type of service request.

Also interesting is why showing zaptel when using DAHDI, from your log:

app_dial.c:883 do_forward: Not accepting call completion offers from call-forward recipient Local/[email protected];1

The context of the E1 link is from-zaptel

This link is used for linking FreePBX to our ancient Alcatel PBX not any external provider. I can’t understand why the Alcatel is sending a forward request back to FreePBX when the number the alcatel phone is forwarded to is also an Alcatel extension

I tried changing the context to from-internal which fixed the problem but it caused lots more.

Should the context be something else rather than zaptel?

Thanks for all the info!

I’m still struggling with this. Does anyone have any further input on what I can try?