Call forward and Caller ID/name

Hi

  1. Problem
    Why is it not possible to change the callid names in Freepbx (extentions)? When you look in the sip_additional.conf file we have: "callerid = device <200>"
    When you then call another extentions we will get “device 200” as callid!
    You can change directly in the file so that, for example, callerid = Office <200>. But this changes every time you make a change in FreePBX (extentions).

  2. Problem
    The call forward feature dont work.
    From extention 200 I call *72 and forward to extention 207. In FreePBX / Panels shown that the extention 200 is forwarded to 207 (CFWD 207).
    But when I call 200 the call is not forwarded…
    Call Forward module is installed (2.8.0.3)
    Anybody have any suggestions?

(I run FreePBX 2.8.0.1)

sip_additional.conf
[200]
deny=0.0.0.0/0.0.0.0
disallow=all
secret=345tdkeo
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
type=friend
nat=yes
port=5060
qualify=yes
callgroup=
pickupgroup=
allow=ulaw
dial=SIP/200
accountcode=default
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=device <200>
call-limit=50

First of all, you can’t make changes to the “additional” files. They’re regenerated at every reload.

I suppose you haven’t taken a good look at the extensions configuration tab. Might want to take a look at the CID Num Alias option.

BF

The CID Num Alias option can only contain numbers! Still displaying “device 200” as call id.