Call Forwading End point displaying issue


(United Arab Emirates) #1

Hello, i have a fresh new installation of freepbx 15. the freepbx has been patched successfully to work with cisco phones. Phones are registered and all call flows are working fine, except when you enable call forwarding on the cisco 8841 phone it does not display. but if you check in the asterisk using “database show” you can see the extension call forwarding enabled and if you call the extension the call forwarding is working.

the only issue is that on the cisco 8841 phone it doesnt show call farding is enabled.

what further can i check.


(United Arab Emirates) #2

i have checked the extensions_custom.conf and this is what i have

; ----- External calls, lock codec to prevent video
exten => _0.,1,Set(__SIP_CODEC=alaw)
same => next,Goto(outbound-allroutes,${EXTEN},1)
; ----- Feature codes, lock codec to prevent video
exten => _*.,1,Set(__SIP_CODEC=g722)
same => next,Goto(from-internal,${EXTEN},4)
; ----- CISCO custom
[from-internal-custom]
; ----- Strip the x-cisco-serviceuri- prefix to make handling the cisco events in the dialplan a little simpler
exten => _[x]-cisco-serviceuri-.,1,Goto(${EXTEN:19},1)
; ----- Group Pickup softkey
exten => pickup,1,Pickup()
same => next,Hangup(normal_circuit_congestion)
; ----- BLF Pickup softkey
exten => _blfpickup-.,1,PickupChan(SIP/${EXTEN:10})
same => next,Hangup(normal_circuit_congestion)
; ----- AdHoc call recording softkey
exten => record,1,Answer()
same => next,Wait(0.5)
same => next,Set(CONFBRIDGE(bridge,record_conference)=yes)
same => next,Set(CONFBRIDGE(bridge,record_file)=${RECORD_PEERNAME})
same => next,Set(CONFBRIDGE(user,quiet)=yes)
same => next,ConfBridge(${RECORD_UNIQUEID})
same => next,Hangup(normal_clearing)
; Cisco SIP phones support displaying diversion information
; ** this part not currently working **
; exten => forward,SIPAddHeader(Diversion: “${SIPPEER(${PEERNAME},callerid_name)}” <sip:${PEERNAME}@localhost>;screen=yes;privacy=off)
; same => Goto(extensions,${CALLFORWARD},1)
; Enable forwarding
exten => _cfwdall-.,1,Answer
same => next,Set(SIPPEER(${CHANNEL(peername)},callforward)=${EXTEN:8})
same => next,Hangup(normal_clearing)
; Disable forwarding
exten => cfwdall,1,Answer
same => next,Set(SIPPEER(${CHANNEL(peername)},callforward)=)
same => next,Hangup(normal_clearing)