Call Flow Control Hint

I have installed a new instant of FreePBX Distro and I can’t figure out how to create hints with Call Flow Control. I have looked under Advance Settings and can’t find anything. Does anyone know how to create these hints.

Check the box in Call Flow Control that says create feature code. You will than see an option to enable hints in the call flow control.

Sorry I was thinking Time Conditions.

Call flow creates hints by default. It is *28 as you can see in the feature code plus the index. So if the index is 0 it would be *280

Here are all my hints. I don’t see them. All of my Call flow controls are *280 - *282. I also looked in the extensions_additional.conf and below the hints is what is in there for my call flow control I didn’t see anything that said hint.
-= Registered Asterisk Dial Plan Hints =-
[email protected] : SIP/1010 State:Idle Watchers 0
*[email protected] : ccss:SIP/1031 State:Idle Watchers 0
*[email protected] : ccss:SIP/1030 State:Idle Watchers 0
*[email protected] : ccss:SIP/1033 State:Idle Watchers 0
*[email protected] : ccss:SIP/1032 State:Idle Watchers 0
*[email protected] : ccss:SIP/1034 State:Idle Watchers 0
[email protected] : SIP/1004 State:Idle Watchers 0
[email protected] : SIP/1005 State:Idle Watchers 0
[email protected] : SIP/1006 State:Idle Watchers 0
[email protected] : SIP/1007 State:Idle Watchers 0
[email protected] : SIP/1000 State:Idle Watchers 0
[email protected] : SIP/1001 State:Idle Watchers 0
[email protected] : SIP/1002 State:Idle Watchers 0
[email protected] : SIP/1003 State:Idle Watchers 0
[email protected] : SIP/1008 State:Idle Watchers 0
*[email protected] : ccss:SIP/1020 State:Idle Watchers 0
[email protected] : SIP/1009 State:Idle Watchers 0
[email protected] : SIP/1034 State:Idle Watchers 0
[email protected] : SIP/1033 State:Idle Watchers 0
[email protected] : SIP/1032 State:Idle Watchers 0
[email protected] : SIP/1031 State:Idle Watchers 0
[email protected] : SIP/1030 State:Idle Watchers 0
*[email protected] : ccss:SIP/1010 State:Idle Watchers 0
[email protected] : SIP/1020 State:Idle Watchers 0
*[email protected] : ccss:SIP/1002 State:Idle Watchers 0
*[email protected] : ccss:SIP/1003 State:Idle Watchers 0
*[email protected] : ccss:SIP/1000 State:Idle Watchers 0
*[email protected] : ccss:SIP/1001 State:Idle Watchers 0
*[email protected] : ccss:SIP/1006 State:Idle Watchers 0
*[email protected] : ccss:SIP/1007 State:Idle Watchers 0
*[email protected] : ccss:SIP/1004 State:Idle Watchers 0
*[email protected] : ccss:SIP/1005 State:Idle Watchers 0
*[email protected] : ccss:SIP/1008 State:Idle Watchers 0
*[email protected] : ccss:SIP/1009 State:Idle Watchers 0
[email protected] : SIP/1990 State:Idle Watchers 0
*[email protected] : ccss:SIP/1990 State:Idle Watchers 0

  • 36 hints registered

[app-daynight-toggle]
include => app-daynight-toggle-custom
exten => *280,1,Answer
exten => *280,n,Wait(1)
exten => *280,n,Set(INDEX=0)
exten => *280,n,Set(DAYREC=beep&silence/1&featurecode&digits/0&de-activated)
exten => *280,n,Set(NIGHTREC=beep&silence/1&featurecode&digits/0&activated)
exten => *280,n,Goto(app-daynight-toggle,s,1)
exten => *281,1,Answer
exten => *281,n,Wait(1)
exten => *281,n,Set(INDEX=1)
exten => *281,n,Set(DAYREC=beep&silence/1&featurecode&digits/1&de-activated)
exten => *281,n,Set(NIGHTREC=beep&silence/1&featurecode&digits/1&activated)
exten => *281,n,Goto(app-daynight-toggle,s,1)
exten => *282,1,Answer
exten => *282,n,Wait(1)
exten => *282,n,Set(INDEX=2)
exten => *282,n,Set(DAYREC=beep&silence/1&featurecode&digits/2&de-activated)
exten => *282,n,Set(NIGHTREC=beep&silence/1&featurecode&digits/2&activated)
exten => *282,n,Goto(app-daynight-toggle,s,1)
exten => s,1,Set(DAYNIGHTMODE=${DB(DAYNIGHT/C${INDEX})})
exten => s,n,GotoIf($["${DAYNIGHTMODE}" = “NIGHT”]?day:night)
exten => s,n(day),Set(DB(DAYNIGHT/C${INDEX})=DAY)
exten => s,n(hook_day),Playback(${DAYREC})
exten => s,n,Hangup
exten => s,n(night),Set(DB(DAYNIGHT/C${INDEX})=NIGHT)
exten => s,n(hook_night),Playback(${NIGHTREC})
exten => s,n,Hangup

; end of [app-daynight-toggle]

Well if I would have retained a little bit more from the training in Cleveland I would have know what I did wrong here. In Advance Settings Enable Custom Device States is False by default. I changed it to true and Poof!!! All of my hints are there now. Don’t know why this is turned off by default but it should be.