Call filtering with a pin/code

First I want to thank everyone here. I’ve read a lot of this board and it’s been a huge help in my business and in my personal life for dealing with phone problems, so… you guys are awesome.

Going to the personal life portion there. My Grandmother has been diagnosed with all sorts of medical stuff, some of it effecting the mind and as a result I am now in place to handle her finances and medical needs.

The long and short of it is, I’ve had her on my PBX for a while now and it’s her home phone she has had forever. I don’t want her bothered by bill collectors, sales calls, medication notifications from the pharmacy etc… that’s my job.

What I’d like to do is have her DID dump to a request for a pin or code (I’m assuming a simple IVR can do this) and only family gets this code. So her sister in Alaska calls, enters the pin, it rings her personal phone, they chat. Any of the other nonsense calls get dumped to my cell.

Quite honestly, I think this is pretty easy but I’m curious if there is an easy way to do this without an IVR?

Thanks again for everyone’s help here. It’s really been helpful.

Rob

That’s what I do, but callers only have to validate once, and then they’re whitelisted: Of Robocalls and Whitelists

I like that idea… Didn’t think of the whitelist… honestly I have everyone’s number so I can easily whitelist them already!

Sweet

Thanks!

1 Like

So I like the idea of using the inbound routes option just for ease and honestly, if we don’t know the number I’m comfortable with them just leaving a message. I can add them later for now (I’ve got a lot of other things to do still so simple and quick might be best/better option for now) I’ll add the IVR later on when I need to.

I tried adding a inbound route with CID filtering but noted this is the log when it wasn’t working…

[2019-07-27 10:43:45] VERBOSE[16160][C-00000201] pbx.c: Executing [[email protected]:2] NoOp("SIP/Flowroute-000001fa", "Received an unknown call with DID set to 1XXXXXXX") in new stack

So I’m not getting a CID?

That doesn’t help and it’s quite odd considering the CID works on the phone

Or is this just because the number isn’t in the phone book?

I don’t know what I was doing. It works now.

A note to anyone the format I needed was +1XXXXXXXXXX

That always depends on the trunk provider.

… and how you process the calls when they come in. The inbound context on the trunk can normalize your numbers so that they look however you want them to look.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.