Call drop consitanly

We just set up a FreePBX on a Windows HyperV as a VM. Everything is configured and working. We started using the server for outbound calls using Softphones to ensure we would not have an issue when changing over to have inbound calls come to the new server

But are having problems now with outgoing calls they consistently drop at about 10 minutes into the call. It happened 4 times already where I’m on a call and then the drops. The truck stays active, but I can’t hear the other person, and they can’t hear me. I open the call again and then the same scenario happens

Any idea what to look for?

I would start by looking at your router/modem configuration for any timers set for 600 seconds on your udp/rtp connections then figure out why it decides to close the connection.

I’m having the same problem on a newly deployed PBXact, but it’s every 15 minutes. What type of router are you using? We are using a SonicWALL.

Disable the SIP “helper” (ALG), it generally doesn’t :slight_smile:

1 Like

I don’t have any of the VoIP enabled on the router, so Enable consistent NAT & SIP Settings & H.323 Settings are disabled.

Then you will need to find out what “router” between the two endpoints are closing the connection at 15 minutesd, I very much doubt it is asterisk per se, so that leaves your VSP and the destination extension and possibly your trunk definition. Check with them

Edit, wait . . . . did you say you disabled “. …Enable consistent NAT…”

If you are using a sonicwall, disable all the VoIP helper stuff.
Then look at your UDP timeout setting on the firewall rules.

We had a similar issue if I remember correctly, it had to do with the UDP timeout being shorter then the FreePBX keepalive.

The calls would dropout after some many minutes (say 10) every time.

Its only been 3 phone calls so far I have not exactly timed it but it is somewhere around 10-15 minutes. I had an 40-50 minute call and I has to call back 2 times.

We are using Untangle for a firewall and also have an old Trixbox PBX with no problem. But that could because with it is an older version of Asterisk.

Here is a wiki from Untangle and I will follow the advice to see if I can solve it

I timed a call now and it is 15-16 minutes when it drops. I’m using a softphone for testing so not sure if that is it. I will test with a hardware phone and see what I get. Diabeling SIP helper in Untangle did not help

I have tried a few possible solutions, from changing the UDP timeout on the router, to decreasing SIP registration time in an effort to force it to register more often. I still have calls dropping after 15mins.
I’ve been told to try session-timers=refuse as a possible solution.

Might not be helpful in your circumstance, but we use Cisco ASA firewalls with SIP inspection / processing enabled and things are flawlessly solid with several dozen users. Swapping firewalls is an extreme solution and only to be considered when all other avenues are exhausted, but having functional SIP inspection for NAT connections is A Good Thing (at least from a Keep It Simple, Stupid standpoint). Let the firewall do the work instead of playing games with quirky NAT workarounds.

Installed Mikrotik router as gateway for PBXact so it was no longer behind Sonicwall. Working great now and I’ve removed the Session-Timers=refuse.

So it appears to be a firewall problem then. I will check with Untangle support

It is not a firewall issue. Here is the solution.

I tried this first which did not solve it because that is for sip Sessions expire after 30 minutes and drop the calls

This worked for me for pjsip (second last post) Outbound Calls Dropping after 15 minutes