Call disconnects after 15 minutes and 30 seconds


(Axiom) #1

My calls keep dropping after 15 and 30 seconds. I am running FreePBX Firmware:10.13.66-17 and Asterisk Version: 11.23.1.


#2

in your trunk sip settings try:
keepalive=yes
and/or
session-timers=refuse


(Axiom) #3

The options I have are:

nat=yes
context=from-trunk
host=losangeles.voip.ms
username=*********
fromuser=*******
secret=**********
type=peer
disallow=all
allow=ulaw
trustrpid=yes
sendrpid=yes
insecure=invite
qualify=yes


(Bob Reiber) #4

sounds like a networking issue to me. what firewall are you running?


#5

I had the exact same issue which I believe was resolved with session-timers=refuse.

I’d be curious what the down side of this setting might be.


(Axiom) #6

Sonicwall TZ-205. The phones I have are the Linksys SAP942


(Jpedalino) #7

Not sure if I missed this… who is your sip provider?


(Axiom) #8

Voip.ms


(Jpedalino) #9

Is it all call’s exactly at 15 minutes and 30 seconds? Inbound, outbound or both?
Things I would Try

  • If its still doing this maybe make a phone call to your Sip Provider and see if it could be on there end

  • Check your network and firewall settings

  • If all else fails Start with the recreation of your trunks. You could also get a free trial with another sip provider to see if you are having the same problems.


(Marbled) #10

Hi!

My bet would be that it’s a firewall configuration problem (I believe someone recently posted a working Sonicwall configuration recently, you might want to compare yours to it) but just in case there are a few things you might want to try…

The only thing missing compared to the configuration they suggest using is the canreinvite=nonat… Could this, by itself, cause this problem I kinda doubt it though…

Have you tried using another one of their servers temporarily? Don’t forget to switch the DID Point of Presence too if you still want to be able to receive calls…

I had some poor voice quality and missing audio with one of their low number servers in an area where they have many and switching to a higher numbered one fixed the problem… I assume the server might have been somewhat overloaded…

Also, is it possible that you set the Max. Call Time for US48/Canadian Calls to 15 minutes in their Account Settings?

Good luck and have a nice day!

Nick


(Dimitrios Manolis) #11

I had the same problem, but my problem was when it was on hold for that long. When I actually had a conversation longer then 15 minutes the call did not drop. I don’t think it’s a firewall issue.


(Marbled) #12

This is the Sonicwall configuration write-up I referred to earlier: