Cab't dial out from PRI

this is version 2.10.1 and has been working for years. I just upgraded it and now I can’t dial out.

I have my PRI outbound set at g0 but this is the error I get.
Whats this outbound 2? Is this new?

-- Executing [[email protected]:3] GosubIf("SIP/7104-00000021", "0?monitor_config,1(from-internal,9188):monitor_default,1(from-internal,9188)") in new stack
-- Executing [[email protected]:1] GotoIf("SIP/7104-00000021", "0?is_exten") in new stack
-- Executing [[email protected]css:2] StackPop("SIP/7104-00000021", "") in new stack
-- Executing [[email protected]:3] Return("SIP/7104-00000021", "FALSE") in new stack
-- Executing [[email protected]:12] ExecIf("SIP/7104-00000021", "0?Set(CHANNEL(language)=)") in new stack
-- Executing [[email protected]:13] GotoIf("SIP/7104-00000021", "1?continue") in new stack
-- Goto (macro-user-callerid,s,26)
-- Executing [[email protected]:26] Set("SIP/7104-00000021", "CALLERID(number)=7104") in new stack
-- Executing [[email protected]:27] Set("SIP/7104-00000021", "CALLERID(name)=POSI - 7104") in new stack
-- Executing [[email protected]:28] Set("SIP/7104-00000021", "CHANNEL(language)=en") in new stack
-- Executing [[email protected]:2] Set("SIP/7104-00000021", "ROUTEUSER=7104") in new stack
-- Executing [[email protected]:3] GotoIf("SIP/7104-00000021", "1?outbound-2,9188,2:outbound-allroutes,9188,2") in new stack
-- Goto (outbound-2,9188,2)

[2013-03-30 16:45:00] WARNING[4945]: pbx.c:5278 __ast_pbx_run: Channel ‘SIP/7104-00000021’ sent into invalid extension ‘9188’ in context ‘outbound-2’, but no invalid handler

It is very unlikely that your PRI carrier will accept a call to 9188, I would examine your outbound routes and Trunks to see what you need to fix.

I have the asterisk behind another PBX. So my dial plan was working for 4-years until this upgrade. I still can dial in without DID settings, but I can’t dial out. doesn’t even start up the PRI

Then your problem is not currently your PRI.

When you get your PRI to dial out correctly and that will generally be longer than 5 digits.

Be careful of upgrades and ALWAYS wave a plan-B restore image ready, at least a FreePBX backup. If you forgot to do that, then just reconfigure your dahdi to the same way it was for the last four years when it worked. There is no one here who can tell you what you did wrong otherwise :wink:

This is my trunks
; Span 1: TE2/0/1 “T2XXP (PCI) Card 0 Span 1” (MASTER) B8ZS/ESF ClockSource
group=0,11
context=from-internal
switchtype = qsig
signalling = pri_net
channel => 1-23
context = default
group = g0

And in outbound route I have it going to g0 My other trunk groups has another trunk group number.

There is no usable.

context = default

in FreePBX. gsig would be a very forward looking ISDN carrier. pri-net signalling seems to indicate that at one time you tried to connect to a non net PBX. Who on earth came up with that file I wonder ? . . .

Maybe you need to slow down and start over . . .

NO, This has worked from Asterisk @ Hoome.
Something has changed. It looks to me that the dial plan is broken and no looking at the numbers dialed. All numbers I dial now are treated as extensions. I guess I could change the PR I type from Internal to PSTN but then I have to deal with all the DID numbers. SCOTTKING HELP !

YES, you changed it, you even said

“I just upgraded it and now I can’t dial out”

which part of that eludes you?

Further dahdi id not loading, look at /var/log/asterisk/full. Or just wait for somebody else to ask what else you FU’ed. I can pretty well guarantee that you screwed up your dahdi setup.

when you get dahdi loading again

dahdi show channels

from asterisk cli will show what you have.

sent into invalid extension is what I’m getting. The dialplan is not sending the call to the PRI as it should.
The PRI is up and working inbound.
escription Alarms IRQ bpviol CRC Fra Codi Options LBO
T2XXP (PCI) Card 0 Span 1 OK 0 0 1 ESF B8ZS 0 db (CSU)/0-133 feet (DSX-1)

and the channels are up.
Chan Extension Context Language MOH Interpret Blocked State Description
pseudo default default In Service
1 from-internal en default In Service
2 from-internal en default In Service
3 from-internal en default In Service
4 from-internal en default In Service
5 from-internal en default In Service
6 from-internal en default In Service
7 from-internal en default In Service
8 from-internal en default In Service
9 from-internal en default In Service
10 from-internal en default In Service
11 from-internal en default In Service
12 from-internal en default In Service
13 from-internal en default In Service
14 from-internal en default In Service

I realty do think someone changed something in the software code.

It has to be with the outbound trunk. The system things the call is an extension call and not sending it out the PRI.

I guess I will call and pay on monday for the fix, but I didn’t want to wait.

someone fixed this now its working. Thank you. ?
PBX Firmware: 1.1004.210.58-1
PBX Service Pack: 1.0.0.0

I tested it again and can’t dial out.

  • Goto (outbound-2,6782222222,2)
    [2013-04-23 20:13:45] WARNING[29399]: pbx.c:5278 __ast_pbx_run: Channel ‘SIP/7104-0000026d’ sent into invalid extension ‘6782222222’ in context ‘outbound-2’, but no invalid handler

Where do I edit outbount-2? I use g0 as my outbound trunks and they are in service taking inbound calls.