Busy tone when FreePBX interacts with phone speaker

First time using Sangoma phones with FreePBX.

Is there a way to turn off the pre-connection quick “busy” alert tone that plays right before something is broadcast through the speaker? 99% sure this emanates from the phone.

Happens in the following places:
Speaker Page --> 1 sec busy tone, then FreePBX beep, then connected
Playing Voicemail --> 1 sec busy tone, then voicemail plays.

I looked in the EPM and couldn’t find a place to turn this off or control it.


That’s not your phone doing it. That is your PBX intercomnthat sends that to all phones. If memory recalls correct it’s a setting in the intercom and paging module in FreePBX global settings you can disable.

Listen to this file I just recorded: https://drive.google.com/open?id=0B3PcUztmLPq7bkJvdmtfUWRBdnc

First part of recording is a speaker page.

Second part is me hitting “play” from voicemail.

Note the alert/busy tone BEFORE the FreePBX tone… Doesn’t happen on Polycom phones… just get the normal beep if configured as such in FreePBX.

Yes when you hit play the PBX send a intercom to the phone. The PBX will play a beep when it intercom.

So there is no way to remove that “beep”? Seems silly that when a user listens to voicemail they have to hear a speaker beep before the speaker is engaged/message is played?

Nothing in the basefile perhaps to disable beep/notify on speaker?

No its hard coded in the firmware. Feel free to open a feature request and we can get it into queue at issues.freepbx.org under the phone project that we should make that a config option.

Thanks Tony!

Issue created. Hope I did it in the right place.