Busy Detection / Busy Tone

Hi there,

I have an strange issue in my FreePBX with snom300 environment.
I have around 150 snom300 and one FreePBX Server serving for these extensions.

What thing actually is happening is when extension A is calling extension B then simply its ringing(good nature), but if extension B is already on another call and extension A is calling then on extension A I can’t hear that extension is busy or a different tone for busy, infact FreePBX is not detecting whether my extension B is already on another call and it should play busy ringtone/message then and there.

Please help with this as I have 150 SIP extension(internally).

The typical setup is that a second call “call waiting” is presented visually and/or audibly to the busy extension, who is given the opportunity to accept the new call (putting the original call on hold or ending it), or to reject it. If this is not desired, it can be disabled on the phone http://wiki.snom.com/Settings/call_waiting , in FreePBX by the user http://wiki.freepbx.org/display/F2/Feature+Codes , or in the extension settings by the administrator.

Once disabled, the call would normally be routed to the user’s voicemail and the caller will hear the “busy” greeting, which could say that the user is on the phone. If voicemail is also disabled for the extension, the caller should hear a busy signal.

If you want the called extension to be signaled, but with a special ringtone played to the caller, it appears that others have asked for this feature, but it’s not yet available. http://www.freepbx.org/forum/general-help/call-waiting-caller-indication .