FreePBX | Register | Issues | Wiki | Portal | Support

Bulk Import VM activation


(United States) #1

I am trying of bulk import extension. Everything is working except for activation of the voicemail. can anyone tell me the header and entry that will enable the vm on import. I am using voicemail_enable as header and have tried all variants of Enabled, enabled, Enable, enable and ENABLED, ENABLE. No luck. everything else is working. FREEPBX 14.0.11

Thanks


#2

just rsync -av --delete from the old machine /etc/asterisk/voicemail.conf and/var/spool/asterisk/* to your recipe


(United States) #3

I’ll be honest, i have no idea what that mean or how that will help me with the import. Also, what old machine are you referring to?

Thanks and sorry for the noobness of my inquiry,


#4

Well, the “old machine” would be the one you exported the "Bulk whatever " from.

Asterisk uses ComedianMail which is a standalone thing that relies on just one file /etc/asterisk/voicemail.conf, if that file is not exactly the same on your “new machine” (I will let you guess what that means) then voicemail just wont work.

rsync is a way to “remotely sync” files between two sources, it can use ssh to do that if the machine is remote, you can also “copy and paste” within putty if man rsync doesn’t work for you


(United States) #5

Okay that make some more sense. However, I downloaded the bulk import csv from the wiki page. So I’ve not exported from any old system. So i guess there is nothing to sync? so if I locate the voicemail.conf file is there something i should be looking for specifically within it that would allow this bulk import. I’m pretty sure the VM works if I activate it in the extension’s gui, I just cant get the import to trigger it on.

I hope that makes sense.


#6

You will have to expand on “the wiki page” it will likely not have your accounts in it.


(United States) #7

so on the Wiki, there is a page on using the bulk imported and from there you can download the CSV with the allegedly appropriate headers. That is what i was using to import the extensions in the necessary format.


#8

I see, if you go to any extension ,submit and apply without changing anything, does that extension’s voicemail start working?


(United States) #9

I can manually configure the VM and it will work. But the import will not activate it and fill in the provided info (i.e. password, email etc.)


#10

And you had these columns set ?

voicemail_enable (Voicemail Enable [Blank to disable]),
voicemail_vmpwd (Voicemail Password),
voicemail_email (Voicemail E-Mail),
voicemail_options (Voicemail Options is a pipe-delimited list of options. Example: attach=no|delete=no),
voicemail_same_exten (Require From Same Extension[Blank/no to disable,yes for enable]),
disable_star_voicemail (To Disable * in Voicemail Menu use Blank/no OR yes),

Also what version of bulkhandler?


(United States) #11

So i figured it out. Unfortunately through much trial and error. I had to combine several forms to get a complete import of all date. There needed to be a voicemail header with default as the entry, as well as a voicemail_enable header with yes/no as the entries. I will post a link to the CSV that worked for future reference. Thanks for all your help!


#12

(Exporting the csv first then editing it would have saved you time)


(United States) #13

ultimately I did that, but that form is woefully inaccurate and incomplete on fields and headers


(Dave Burgess) #14

That needs to be documented so it can be fixed. @jfinstrom worked on that quite a bit last summer, so I’m sure he and the rest of the team want to make sure it’s accurate. It’s an awesome tool, but if it isn’t working right, it makes it a challenge that we, the user community, end up having to help with and support.


(TheJames) #15

the headers are based on installed modules. Each module supplies its respective headers.


(system) closed #16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.