Bulk Extensions: Extension already exists

I’m running FreePBX 13.0.1alpha37 using the Bulk Extensions module. When I run the import on my CSV I get

Row 1: Headers parsed.
Row 2: Extension 101 already exists

https://www.dropbox.com/s/fzpcegv4pm1icqt/ExtensionsImport.csv?dl=0 is the first line of the import with important info removed … I think

I even created a different extension, ran the export, changed the action to delete (that worked) and then ran it again with add and with edit. Neither would put the extension back in. I would just get the following –

Row 1: Headers parsed.
Row 2: Extension 1101 already exists
Row 2: Edited: 1101

Apply the config and still nothing

PS - I am still fairly noobish so I’m sorry if I’ve missed something obvious. I really like the changes in this alpha so that’s why I’m trying to setup a system like it is production. I want to see how some of these changes work in practice.

You answered your own question, it is alpha, post a bug in the bug tracker specifically saying you are using alpha software and just don’t expect it to work in any usable way for a production system, (it’s alpha, got it yet ? it is the responsibility of all users who choose that path to make it to beta and then ultimately production )

Since this is the beta program section I figured this is where people in the know wanted reports of such things. Ill see if I can get it in the bug tracker. Thanks for letting me know.

Actually it’s still alpha (alpha < “Beta Program Issues”) so doesn’t belong here yet. You chose the right place though :wink:

I have to say, before you waste TOO much time on this, we recently spent a good chunk of time at the FreePBX DevConf rewriting bulk importing for 13. It should be published in the next few days.

1 Like