Bulk DID Import Failing

Anyone experiencing a lockup when attempting to import DID’s from .csv file after importing bulk extensions? The first one seems to load and then the GUI locks on a blank screen. We are on distro 2.10 with Bulk DID module

Thanks for looking! :slight_smile:

Downgrade it to a lower version…had the same thing, but i cant remember which version i used but worked on though.

I just tested this on a test system and verified that works for me. If you getting a blank white page, can you double check your apache logs and look for a FATAL error, and let me know what you see.

Thank you so much for your replies, gentlemen! :]

In checking error logs located at /var/log/httpd, I am seeing:
PHP Fatal error: Call to undefined function cidlookup_get() in /var/www/html/admin/modules/bulkdids/bulkdids.inc.php on line 0

I should also add, when executing the load and then refreshing my window after receiving a white screen, I receive “A route for this DID/CID already exists! => 7201/’)”

So, it appears to add the first route in the list and then barfs.

I have executed a yum update and still no improvement to this issue. :[

I’m also not having any success finding anything when searching for this PHP error.

Do you have malformed data in the CID lookup module? Are you trying to dip an outside source?

Not much boundary checking is done on that field.

Hi Scott,

Thanks for helping direct me towards the right path. We did not have the “Caller ID Lookup” module installed. (I’m guessing the warning “Pay attention, name lookup may slow down your PBX” was enough to warrant removing it along with other modules we wouldn’t be using in an attempt to maintain the leanest system possible. That and we are not opting to use any external directories at this time, which is initially what was believed this module was for.)

After installing this module back in, my bulk DID imports are creating the inbound routes, but with a “WARNING: CID Lookup NOT added, index does NOT exist.”

Soooo, now I’m searching info on this error. One post (http://www.freepbx.org/forum/freepbx/installation/callerid-lookup-module-not-working-correctly) suggested installing curl-devel. However, this did not resolve my situation.


After more testing, I found the error you were hitting with bulkdids and should have something checked into svn later today, so they are available when we roll another bulkdids release.

Your efforts are greatly appreciated.

And I realize I may be pressing my luck here…Any chance an extra column might be added in the Bulk Extension import for a direct DID association with the extension? I can’t speak for the rest of the community (and appologies if someone else has already requested it), but this is pretty much all we use in defining the majority of our inbound routes (ie bulk creation). Of course, there are the exceptions which we fine tune in the inbound route itself. But, for the purpose of “getting started” it would be a little more efficient to create both in one import. If it hasn’t been requested, please let me know and I’ll submit a ticket. Thanks again for your time and efforts.

Can you please open a feature request ticket for the last request so that it’s on our radar.

You got it. I referenced this thread.

Thanks again!

Tracey Thomas
Washoe County