Bug in Asterisk SIP Settings

I have dynamic IP (dyndns) and I specified that in Asterisk SIP Settings.
I was not able to register my trunk to my Voip supplier.
When I change to static IP in Asterisk SIP Settings all worked.

Sounds like a DNS issue on your box to me. I use FQDN on all my boxes with no issues.

Maybe I was unclear.
I also use FQDN in ‘External IP’ but when I in ‘IP Configuration’ choose ‘Static IP’ then it works but choosing ‘Dynamic IP’ it doesn’t … hmmm
It is not a DNS issue in my box