BUG? How to increase timeout in Endpoint Manager?


#1

Commercial Endpoint Manager with Yealink T46S phones. When I edit a BaseFile and click “Save and Rebuild Config(s)”, after waiting 30 seconds, I get an error “Maximum execution time of 30 seconds exceeded”. We have 20 phones, and it looks like it only updates 9 of them before timing out. I’m surprised that it takes a few seconds to update each mac.cfg file, and I really need it to update all 20, or even 100 phones without timing out. Is there a timeout setting, or can this be fixed by a quick module update? Right now, some of my phones don’t have my latest settings changes.

Thanks!


#2

gherbstman shared a workaround with me on this bug’s page:
https://issues.freepbx.org/browse/FREEPBX-14255

If you go to to the Template editor page, which is under the “Brands” subheader in the Endpoint pop-out menu, you can select “Save and Rebuild Configs” there, and it does not time out. It was able to save all 20 of my phones without an error. So this is a good work around for everyone. But please, Sangoma, fix the Basefile editor page so it doesn’t time out.


(Dpbx71) #3

Looks like this is still an issue in FreePBX 15.0.16.75


(system) closed #4

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.