BUG: deleting an extension doesn't mark database as needing reload

We have several systems where we just used the web admin to update the Core to v15.0.12.98 and PBX API to v15.0.3.22. After doing that the Apply Changes button no longer appears correctly. Immediately after you make a change the button is there. However, if you refresh the web admin it no longer appears. An examination of the log files shows the system did not apply changes.

I’m using Chrome and have cleared browser cache, still nothing.

Any ideas as to what has gone wrong? Is this a bug or has something been messed up on the 5 systems I’ve tested this on?

I just noticed that these symptoms only happen when DELETING an extension. If you make some other sort of change (e.g. deleting an inbound route or adding an extension, then it works correctly). So it seems like there is a new bug with the web admin when deleting extensions.

Have you tried a different browser, e.g. Firefox?

Just tried in Firefox and Edge, same result. (which I’m glad for because if it were a "FreePBX doesn’t work correctly the world’s most used browser that would have made me sad :slight_smile:)

I can confirm the report on core ver. Delete an extension and see the apply config button. Refresh the page or browse away and apply config button is gone

@darrenhollick pls open a bug report https://issues.freepbx.org/

Lorne, thanks for the confirmation! [FREEPBX-23249] Deleting an extension doesn't mark database as needing reload - Sangoma Issue Tracker has been created.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.