Broken modules after restore from another system

I wanted to migrate from an old system to a new one. I upgraded all the modules on both systems to the most recent version (2.5.1). I then did a backup on the old system, transerred the backup to the new system and did a restore. All seemed fine, except that when a call was placed from one extension to another, the callerid was “device xxx” instead of the extension name. By clicking on all extensions and pressing submit, this problem was resolved.

However, I now have four broken modules:
fw_langpacks 2.5.1 Broken
dundicheck 2.5.0 Broken
fw_fop 2.5.0.1 Broken
queueprio 2.5.0.4 Broken

I cannot fix these by trying to “install” the modules, as I get a “Cannot find module” on the install. I tried downloading the latest freepbx-2.5.1.tar.gz file, and runnig install_amp, but I get the same symptoms.

Any ideas?

Peter

I ran uninstall, and although it complained, the modules were no longer listed as broken.

I was then able to install the modules again.

(I had set:
magic_quotes_gpc = Off
memory_limit = 100M
in /etc/php5/apache2/php.ini
because of two other warnings I was getting)

I think some work has been going on in this area recently.
Just a note that it’d be nice to fix the issue at some point in the future…

(The uninstall fix works)