Bria cloud module / stretto / rtp using local ip STUN PLEASE? One way audio

I’m trying to troubleshoot my first bria stretto configuration with freepbx. The freepbx server is in the ‘cloud’. With the module, bria stretto registered without issue. However, only one way audio, whether outbound or inbound calling. Never had that issue before.

I chekced asterisk while dialing. SIP traffic is having no problems taking in calls or dialing out. However, RTP traffic is using the computers LAN IP address, so no matter if the call is inbound or outbound, I’m getting now audio from the bria smartphone. HELP!! I have no idea what to do from here, there are no STUN or ICE settings in bria stretto like there were with bria 3/4.

Is your primary extension that stretto is tied to set to NAT yes?

It was originally yes (force_rport.comedia), and I’ve tried no, as well. I’ll give all other nat option s a test run.

None of the individual extension nat settings worked. The server itself has a locked down public IP address, and looks to be configured correctly. Regular bria 4 is able to connect to it and pass voice traffic without any issues.

Hmm… I think I’m wrong about the reason it’s not working.

Probation passed - setting RTP source address to [trunk IP]:17764
Probation passed - setting RTP source address to [My PublicIP]:61346

Finally got back into messing with this.

Thank you Tony, this was the issue. The extension 999[hostextension] does not show up as an extension within the Extensions module, nor does the main extension that it uses affect the settings applied to the 999[“host” ext #]. I had to edit the extension within sip_additional.conf then reload asterisk. Not sure why the bria cloud solutions manager didn’t just mimmick the settings of the linked extension.

Also, there seemed to be a typo. For that bria cloud solutions extension, trustrpid and sendrpid show up as sendpid=no and trustpid=yes for that extension only without the ‘r’.

As I figured, every time I reload freepbx, the configuration file changes.

My main extension, let’s call it 402 is setup as:


no matter what, even if I recreate the bria extensions, 999402 is always:


So there’s no way to edit the extension manually, and the bria cloud services module isn’t creating the user correctly.

Bria cloud solutions module is up to date (12.0.11). User Management is 12.0.27.

Is this a bug?