BLF not Working after Migrate from Elastix 2.5 to FreePBx

hi, guys thanks for time and help, i read all post from community but i don’t get a solution i performance a migration from Elastix 2.5 to Freepbx 13

Elastix 2.4
Phone: Fanvil C600

Freepbx 13
Phone Fanvil C600
BLF: not Working

i have to do something especial in freepbx?

That depends a little bit on the BLF. Check to make sure the hint associated with the BLF key matches your hints.

thanks and where i can check or configure my hinst in freepbx?

The easiest way is to log onto the console, connect to the CLI (“asterisk -vr”) and type “core show hints”. This should give you the list of all of the hints that are active in the system.

ok, i know that part for example i have 202 hints registered but the blf is not working

Now you have to set up the phone so that it monitors one of your 202 hints. Are you managing your phones by hand, or in EPM?

by hand

OK. In the config for the phone, you should find the “hint” text that monitors the hints. Set that so that it matches the hints you want to watch and the phone should do the rest.

The BLFs you want to monitor will be applied to the buttons as they make sense.

I don’t have any experience with the Fanvil C600 - but I do have some extensive experience with the Cisco 7960 running under SCCP. It should be relatively similar. One of the entries for each button is the watcher, which matches the hint you want to watch. On the Cisco (for example), the BLF entry is the number to dial when the button is pushed, the “display”, and the Hint to watch to toggle the BLF on and off. You should have a similar structure.

The only really tricky part is that the Asterisk report of the hints cuts them off after 28 (30?) characters, so long ones get truncated in really ways. I’m pretty sure you can grovel through the database and get them, but it’s been a long time since I’ve played around with BLFs, so hopefully one of the folks that’s more current on them can jump it.

ok, thanks for example i have this hints:
8300@ext-local : SIP/8300&Custom:DND8 State:Idle Watchers 0
i want to monitoring extension 8300 from extension 8316
but is not working

hi, some body have the solution to this problem? i this using CISCO SPA504G and i have the same problem the BLF is not working on this PBX System.

1 Attendant Console
2 Server Type to Asterisk
3 Attendant Console Call Pickup Code to **#
4 Extension to Disabled
5 Extended Function put in: fnc=sd+blf+cp;sub=1206@$PROXY

When the monitored extension is available, it shows green. Red when on a call or busy. Blinking red when ringing. Orange if there is an error in the syntax.

The extension is Orange all time and i doble check the configuration, what i have to check or enable on the pbx?

<— SIP read from UDP: —>
SUBSCRIBE sip:[email protected] SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK4508629401076139805;rport
From: “UserTest” sip:[email protected]:5060;tag=4488115152
To: “8300” sip:[email protected]
Call-ID: [email protected]
Contact: sip:[email protected]:5060;transport=udp
Authorization: Digest username=“8316”, realm=“AST01”, nonce=“2a5e8b71”, uri="sip:[email protected]", response=“aa1b1f02c7d99d43e8a1fc918a8a1c9f”, algorithm=MD5
Max-Forwards: 70
User-Agent: Voip Phone 1.0
Expires: 3600
Supported: eventlist
Event: dialog
Accept: application/dialog-info+xml,application/rlmi+xml,multipart/related
Content-Length: 0

— (15 headers 0 lines) —
Creating new subscription
Sending to (no NAT)
Found peer ‘8316’ for ‘8316’ from
Looking for 8300 in subscribe (domain

<— Transmitting (no NAT) to —>
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP;branch=z9hG4bK4508629401076139805;received=;rport=5060
From: “UserTest” sip:[email protected]:5060;tag=4488115152
To: “8300” sip:[email protected];tag=as3adcdb02
Call-ID: [email protected]
Server: Asterisk PBX 11.25.1
Supported: replaces, timer
Content-Length: 0

Monitoring from 8316 to 8300
8300@ext-local : SIP/8300&Custom:DND8 State:Idle Watchers 0