FreePBX | Register | Issues | Wiki | Portal | Support

BLF - Not showing ringing and not allowing pick up - shows ** instead


#1

We have a couple of extensions that are members of the same call group and pick up group. Let’s call them 1000 and 2000. They each are set up on each others Polycom VVX 600 phones as BLF buttons via EPM.

On their previous hosted PBX from another company, whenever 1000 rang, the 1000 BLF button on 2000’s phone would indicate that 1000 is ringing. 2000 could then press the 1000 BLF button and pick up 1000’s incoming call. However, now that I’ve switched them to FreePBX, the BLF button does not indicate ringing, and when pressing it, the screen shows ** in the dialing field, when I presume it is supposed to show **1000 and automatically dial instead of just sitting there waiting for a press of the dial/call button.

Before I lodge this as a bug in the issue tracker, I’d like to make sure there is nothing special that needs to be done to enable the functionality I am expecting above.


(Tom Ray) #2

What platform was the previous company using? I’m going to guess BroadSoft which Polycom has a relationship with and provides enhanced/specific functionality to phone with the platform.

The phone’s config is setup to use “**” as the pickup command and it is prompting you for the extension. This really isn’t a “bug” per se but more of how to make this work with Asterisk/FreePBX.


(Tony Lewis) #3

Sounds like you don’t have the button actually setup for BLF. How did you configure your phone?


#4

It was configured via EPM. See attached image.


(Tom Ray) #5

Try BLF+Xfer


#6

Tried that as well - same result.


(Tom Ray) #7

OK, like I said this is not a bug. This is now a case of making Asterisk and Polycom play nice together. There are a few ways to do this such as macros and getting deeper into the Polycom configs. That being said EPM becomes more of a hindrance than help. It is not designed to do that advanced level of programming. It can if you edit the Basefile like mad and write the macros and add other settings into it.

As someone who has deployed BroadSoft+Polycom and Asterisk+Polycom there is a HUGE difference in interopability between those two mixtures and for the most part the latter sees a feature loss.

I get your pain, this is on my list of things to figure out for Polycom phones right now. Not gotten far on it yet but if I get something I’ll post it here.


(Tony Lewis) #8

By default EPM should work for BLF buttons. Did you factory reset the phones before having them pull config from EPM to make sure all settings saved before on the old platform are erased.


(Tom Ray) #9

I’m not saying that it doesn’t. However, when you try to do a Call Pickup via the BLF or BLF+Xfer options the Polycom uses it’s Call Pickup Prefix which defaults to ** via the EPM to match Asterisk. The phone will still prompt for the extension to pickup.

So it’s not adding the requested extension to the ** which is a programming issue on the phone and/or how it is receiving the information from the PBX.


#10

Yes - we did a complete factory reset on ALL phones before moving over.


#11

Correct - if we enter 1000 after the ** appears and then press the call button, it does pick up. I was hoping to automate it based on the BLF they were pressing like it did before, but I guess we’ll have to forgo it for now if that functionality doesn’t exist. I set up a speed dial for **8 and instructed the user to press that when they see the BLF for 1000 ringing, but it works only some of the time according to them. I tested with them just now and saw that it didn’t pick up the ringing extension (again, they are in the same call and pickup groups), but I also know that it was working last time I tested it with them.

(I did just confirm that I was incorrect about it not signaling ringing - it does show the extension as ringing on the BLF button, so that’s working as expected).

Would I technically open a feature request for this?


(Dave Burgess) #12

Instead of using “Directed Call Pickup”, have you tried the group pickup option (IIRC, it’s “*8” - check your Feature Summary)?


#13

For some reason I had **8 but I’ve changed it to *8 - testing now.

EDIT: I had mentioned earlier that I had set up a speed dial for **8 on a separate button but it was only working sporadically. Checking to see if the change to just *8 will fix this.


(Andrew Siplas) #14

We had trouble until manually updating polycom firmware to the latest available–Sangoma’s EPM is showing firmware that’s WAAAAAY old (September 2016).

We find two things with upgrade–the phones will trust Let’sEncrypt certificate, and also BLF seems to work a lot better, though for directed pickup more is needed from the pjsip stack in terms of dialog-info per https://issues.asterisk.org/jira/browse/ASTERISK-24601

You could try using chan_sip perhaps with a few tweaks to configuration from what I see, but that is deprecated and no longer developed as far as I know–not really viable long-term I’d think.

There’s an issue tracking the very old Polycom FW: https://issues.freepbx.org/browse/FREEPBX-17829