Blank screen after upgrade


I’ve gotten myself in a bit of a bind. I used the upgrade module to upgrade to FreePBX 2.4.0. I selected only the framework module for upgrade, and that upgrade appeared to be successful. When I hit the “return” link on the orange page, however, all I got was a blank page in my browser. Now, when I visit my admin page ( all I get is a blank webpage. I’ve tried clearing my cache, reloading the page, even restarting apache on the server.

I’ve also tried upgrading manually by downloading the tarball and running the install, which also seems to complete successfully but still leaves me with a blank admin page.

Any suggestions?

If I “downgrade” to 2.3.1, the web interface comes back and the system seems to process calls normally. Re-enabling the 2.4.0 framework, however, results in the same blank page.

Any ideas would be greatly appreciated.

When viewing the apache error logs, it became apparent that the system was still trying to load the outbound groups module and was dying with a “cannot redeclare class” error.

Manually deleting the /var/www/html/admin/modules/outgrps directory resolved the problem.

If you are having this blank page issue, I suggest checking your apache error logs, which can usually be found here:




that is interesting - because the framework only loads the modules that are enabled, IIRC - it should not try to even include them otherwise.

$active_modules = module_getinfo(false, MODULE_STATUS_ENABLED);


  foreach($active_modules as $key => $module) {
    //include module functions
    if (is_file("modules/{$key}/")) {