Blank Free PBX Screen

Installing FreePBX to replace our old trixbox system. Had it up and running and starting to migrate all the phones to it.

Got a notice this morning about some modules being updated. One of the updates was the digimaddoninstaller which had not been installed previously. Told the system to down load and install it, and now when I get into the GUI I get nothing but a blank screen the url after I logon is http://…/admin/config.php.

I’ve restart httpd, asterisk, cleared my cache, tried other computers but all give the same blank screen after I log in.

httpd error_log has
[Sun Sep 08 12:17:48 2013] [error] [client 209.219.235.2] PHP Fatal error: Call
to undefined function dl() in /var/www/html/admin/modules/digiumaddoninstaller/
libdregister/digium_register.php on line 22, referer: http://…/
admin/config.php

how can I manually remove this so that I can get my GUI back up and running
I don’t want to start randomly deleting things but I need to get the interface working again.

Never mind, found in your wiki how to disable a module from linux. Disabled that module and now my GUI’s back

I think this is a new bug. It seems that the Digium Add-ons module is now being installed as part of the Distro. This new module is causing problems.

Its a bug in this Digium module that they supplied. If you are missing the PHP function it bombs out. The FreePBX Distro 4.211.64-6 includes this function and the upgrade script also installs it. Hence why you should always keep your Distro updated.

Hello! This issue has been resolved. Please run this from the ssh command line:

amportal a ma upgrade digiumaddoninstaller

I started this project about a month/month and half ago with the latest distro available at that time. I have been updating modules as the system tells me religiously, and it was on one of the these updates that I noticed the new digiumaddoninstaller, and selected to download and install which caused the problem.

My question about keeping my distro updated, is their something more that I should be doing other than the module updates when I get informed about them to keep it updated? I presumed that by applying these as they come out I am keeping my distro updated. I didn’t see anything in the doc that I’ve read (but I haven’t read the entire wiki) that I need to so something other than apply updates as they are released to keep my system updated.

We provide updates that update not only FreePBX modules, but parts of the distro the modules can’t touch. See this wiki link for instructions http://wiki.freepbx.org/display/FD/Updating+FreePBX+Official+Distro

You can also add the sysadmin pro module and run these updates from the GUI, or even schedule and automate them.

Since I’m realtively new at this, I just want to make sure I understand what you are saying.

Don’t install this via the GUI, but if I want this module, use the command above in a linux shell and this will install the module correctly. The Digim Addons module is currently disabled. See the status below

Digium Addons 2.11.0.1 Schmoozecom.com Disabled; Online upgrade available (2.11.0.2)

Would applying the upgrade through the GUI to get 2.11.0.2 also fix the problem?

If the GUI is broken how could you use the GUI to upgrade the module. That is why I provided command line options

Well, the previous comments says that if I get my firmware to -6 (at -1 now) then the GUI would work, plus I noticed that the module itself has changed from .1 to .2.

I hadn’t realized that the firmware level had to be maintained differently, nothing was telling me that is had been updated and assumed that by keeping the modules up to date everything was good. Working on getting the firmware updated then will try again with the GUI to add this new module.

I don’t see that I need the module yet anyway, so I’ll wait until the purchase of the sysadmin pro is complete and I get the firmware updated and then give it a try again. Now is the time to do these things, since it’s still just in test and I can make changes (and break things) before we move it and put our customer service reps on it).

For clarification firmware is more like all of the elements around FreePBX. Anything that you don’t visually see in the FreePBX GUI. All of the FreePBX updates are done through the web interface

OK, I understand the concept of using the word firmware to describe the elements around FreePBX, even if it’s not entirely accurate. As this environment is new to me, I didn’t see the difference between the FreePBX “Firmware” and maintaining the system with sysadmin module admin. I’ve purchases the sysadmin pro, and I see the updates and schedule for installing updates.

I’ve got the system to -6 level and will try the GUI to download and install the Digum Addons again later (from the comments tony made earlier this would have worked if I was on -6 which I wasn’t it was -1). If that doesn’t work, I have the CLI version to remove and then install via the CLI.

A final question. The system was good about telling me all the module updates when they come out, and I see in SysAdmin Pro that I see updates to the “Firmware”, will it now tell me when these are available also, or is there someplace I need to manually check periodically to keep that up to date also.

I do not want to use the auto update feature, I never allow that to happen on a production system, any updates that need to be applied need to age a little, and be manually installed so that I know what’s going on, and preferably a back up made before the install in case things like what happened to me yesterday don’t happen on a critical system like our customer service (well whole company) phone system. Since it’s just still in development/testing mode I haven’t been as picky about the backups before I apply service.

FreePBX upgraded to -6 firmware.

System tells me that the .2 level of digium addon module is available. Click on Install and process.

I get

Please wait while module actions are performed

This Module Requires The Digium RPM to be installed (php-digium_register-3.0.5-1_centos6.i686.rpm). Please see this page for more information: http://wiki.freepbx.org/display/F2/Digium+AddonsError(s) installing digiumaddoninstaller:
Failed to run installation scripts

Follow the link to the instructions and it says

To be able to run this module you must have installed the RPM php-digium_register-3.0.5-1_centos6.i686.rpm
On a FreePBX distro simply run this command from the ssh CLI:
yum install -y php-digium_register

When I run that I get
yum install -y php-digium_register
Loaded plugins: fastestmirror, kmod, security
Loading mirror speeds from cached hostfile
Setting up Install Process
Package php-digium_register-3.0.5-1_centos6.x86_64 already installed and latest version
Nothing to do

So the RPM is installed but the GUI install process won’t run the install scripts.

Haven’t tried the manual process yet.

Not actually sure when the RPM was installed, because when I saw the message about it needing to be installed and ran the yum command to install it told me that was already installed. But since this system is still in development it’s easy to bounce during the day.

Just restarted it, re-signed in, and still get the same results. Says it’s going to install .3 and then complains that the RPM isn’t installed.

However, I removed the RPM and re-installed it, and then Module Admin said that the .3 version was available. Selected download and install and I was finally able to get the GUI to install the module!

Thanks for all your help, now on to see what it does and finish getting all the phones onto the new system and ready for the migration.

I was a bit too restrictive in xx.2 try the new release xx.3 and you should be golden

Great, however when I click check online, it does not say that there is a new version of this module.

It’s definitely there. Just checked on a remote system. 2.11.0.3

On the module administration screen I see:

Digium Addons Schmoozecom.com Not Installed (Locally available)

Note: the Version column is blank

I click on the name and it opens up with to show “Action” and “Description”. In the Action radio buttons I change it from No action to Install, then click process, it brings up the next screen

Module Administration

Please confirm the following actions:

Upgrades, installs, enables and disables:

Digium Addons 2.11.0.2 will be installed and enabled

I click on confirm and then I get the message about having to have the RPM installed, and go back to the main module admin screen.

If I click on check online again, when I click the module name I see Action, Description, changelog. Clicking Changelog shows 2.11.0.3, 2.11.0.2, 2.11.0.1 (plus some verbage on each line about the change). I select Action - Install and click process, I get

Please confirm the following actions:

Upgrades, installs, enables and disables:

Digium Addons 2.11.0.3 will be installed and enabled

Clicking Confirm brings up the same messages about the missing RPM

Please wait while module actions are performed

This Module Requires The Digium RPM to be installed (php-digium_register-3.0.5-1_centos6.i686.rpm). Please see this page for more information: http://wiki.freepbx.org/display/F2/Digium+AddonsError(s) installing digiumaddoninstaller:
Failed to run installation scripts

I’m guessing it’s not actually loading down the new .3 version, even though now it knows about the .3 version.

Have you restarted apache at all after installing the RPM

Hi
I’m try to do it:

[[email protected]]# yum install -y php-digium_register Loaded plugins: fastestmirror, kmod Loading mirror speeds from cached hostfile Setting up Install Process No package php-digium_register available. Nothing to do

May be missing any repo in my system?