Blacklisting international numbers


#1

I was trying to blacklist calls made from a certain number in Cambodia. The number is in the format 855nnnnnnnn. 855 is the country code.

When this call comes in, the caller presses 101 for the extension from the IVR. The call goes to voicemail because it is intentionally unanswered. When extension 101 dials *32, the system says the last caller was 102, not the incoming call from Cambodia.

I can only assume that the Cambodian carrier is sending the CID with the 1 prepended. it records it as 1855nnnnnnnn

If I enter the number manually into the blacklist module, the caller is sent to the correct destination.


#2

Same old ‘same old’. As ever . . . .

Without logs we are all guessing, post any supporting logs.Please don’t post them “in line”


#3

Reported on my Android. No access to logs. Later


#4

It’s difficult to test from Cambodia. DTMF signals from my mobile are not always transmitted. I’ll need to get someone in the US to help me out. It doesn’t seem to be just international numbers. Sort of hit and miss


#5

The problem is with the Cambodian phone not always sending the DTMF correctly. I had a friend in Vietnam call and it worked fine.


#6

That will be a problem, set dtmf logging on and perhaps inform the carrier of their non-compliance if needed in the left most column of ‘operators’ referance at


#7

I would expect a big shrug of the shoulders. Customer service is not a priority here.

Any special instructions for a DTMF trace?


#8

Not really , just enable in your log file settings and watch the logs


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.