Blacklist Module Not Working When Allowlist Module is Enabled

Yes you should uninstall the current version and install the new version.

I visited your link and it says “401 - Access is denied”. I was able to login to that website successfully using my freepbx account but I cannot access your repo. Am I missing something?

I enabled public access just now, see if you can get access.

1 Like

Yes, I can access it now. Thank you. I’ll try it & get back to you.

I had a chance to mess with it just now since I know I probably won’t get a chance at work tomorrow…At any rate, I had issues compiling it so I just hand edited the functions.inc.php (I did not see any other files that were modified by you except module.xml, which I did not change on my end.) file with the changes you made. That did not make a difference. The phone number still has to exist in both Allowlist and Blacklist before that number will be Blacklisted.

Granted, by me hand editing the file, I am not sure if the Allowlist module or FreePBX used the changes or not.

At this point, I reverted all changes, uninstalled and reinstalled Allowlist just to make sure all files were reverted back to the official repo state.

I know this was not the best method to try this, but I had a hard time compiling it and I did not want to risk messing up my FreePBX install. My boss would definitely not be happy with me if that happened lol I’m sorry.

The function.inc.php routines are not called unless you uninstall and reinstall or disable and enable the allowlist module in module admin. You will have to look in extensions_additional.conf in /etc/asterisk to see if the changes were applied (this happens when you press the red “apply config” button in the upper right corner of the module admin screen following processing the install operation.

Search for the string BLDEST and ALDEST in extensions_additional.conf – you should see them switch places in the file – BLDEST should come first.

1 Like

If you hand edit the file functions.inc.php in /var/www/html/admin/modules/allowlist and then disable and enable the module it should apply those changes to the extensions_additional.conf file.

1 Like

I just tried it and I can confirm that it now works as expected. If I enter a number on the Blacklist only, it works as expected.

I hand edited the file again, but this time, like you said, I disabled and enabled the Allowlist module. I did not disable and re-enable it last night.

I’ll revert all changes and wait for this fix to be available on the official repo. Thank you for looking into this and getting this fixed! I appreciate it! :slight_smile:

2 Likes

It should be available on the edge track now

2 Likes

Thank you. But, I’m gonna wait for it to hit the Stable repo. Hopefully, it does soon.

1 Like