Bizarre behavior, ghost calls!

I believe this started happening after the last core and framework updates.

For some reason, many calls to the outside are jittery and disconnect initially.

Then about 20 minutes later, (time varies) the outside person gets a “ghost call” from my FreePBX system and "there’s nobody there"
LOL

I have witnessed it myself. Wife called my cellphone from home, then like an hour later, we are sitting together in the house, and I get a call from her on my cell, but she’s right by me, and didn’t call.

It’s a mystery, is anyone else experiencing this?

Thanks.

FreePBX 2.9.0.5
Core 2.9.0.1
FPBX Framework 2.9.0.5
Asterisk 1.4.31

Aw Man! I was hoping it had something to do with the latest module updates, and there would be a fix… I assume from the lack of response that it’s just me.

THis is getting worse. I have rebooted the server, etc, but it keeps happening. If someone makes a call from inside, out to the world, the call rings then you hear the other party very distorted. Then it disconnects. try again, and sometimes you get through.

THe weirdest thing is that the called party then recieves a couple “hangup” calls later from our number!!

What is going on, and where would I look? It started happening after I did the last core and framework module updates, but that may be coincidental.

Thanks!~

I have experienced that behavior a long time ago when testing Asterisk. I can’t remember the solution now, but it had to do something with the firewall and version of Asterisk and NAT settings.

If your calls are jittery then I would suspect the firewall and bandwidth issues.

Thanks Mikael, I have nothing in the firewall that has changed, in fact, nothing on the system has changed other than the modules I mentioned.

Could it possibly be my SIP Provider? What would cause the “ghost calls”?

Thanks for your help!

Look at your logs at /var/log/asterisk and see if you can trace something there.
set verbose to 5 and debug to 3 and make some calls.
I would suspect Asterisk and some sort of NAT problem.

Try removing the router from the system to verify if it is a nat issue, if you are using Nat you will have to reconfigure the server to reflect this I am guessing.
Your router could be going out if your getting jitters and having Nat issues too!

I have just done all the updates myself and have had no issues, as for why it makes the call again later is a bit weird, also you might want to check your server resources and processes to make sure the server is not bogging down during a call.

The Router/firewall and Asterisk box are on the outside. The phones are inside the firewall. internal extension to extension calls, VM, etc (which do traverse router/firewall) seem to not have an issue.

Here is an example from my log this morning. I called a number, 247-1611 locally, and here is the output. The call sounded like TWO calls had been made offset by a second or so, the audio was doubled and jittery.
If you can see in the log what’s not right, please let me know.

Thanks for you help!

Lee

[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:1] Macro(“SIP/100-00000488”, “user-callerid|LIMIT|”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:2] Set(“SIP/100-00000488”, “MOHCLASS=default”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:3] Set(“SIP/100-00000488”, “_NODEST=”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:4] Macro(“SIP/100-00000488”, “record-enable|100|OUT|”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:5] Macro(“SIP/100-00000488”, “dialout-trunk|4|2471611|”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:4] Set(“SIP/100-00000488”, “DIAL_NUMBER=2471611”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:4] ExecIf(“SIP/100-00000488”, “0|Set|TARGET_FLP_4=12471611”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:6] ExecIf(“SIP/100-00000488”, “1|Set|TARGET_FLP_4=15052471611”) in new stack
[Jun 5 08:38:23] DEBUG[22706] app_macro.c: Last app: Set|TARGET_FLP_4=15052471611
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:9] Set(“SIP/100-00000488”, “DIAL_NUMBER=15052471611”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:13] Set(“SIP/100-00000488”, “OUTNUM=+15052471611”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Executing [[email protected]:20] Dial(“SIP/100-00000488”, “SIP/VP-SIPSJCA/+15052471611|300|TW”) in new stack
[Jun 5 08:38:23] VERBOSE[22706] logger.c: – Called VP-SIPSJCA/+15052471611
[Jun 5 08:38:36] VERBOSE[22706] logger.c: == Spawn extension (from-internal, 2471611, 5) exited non-zero on ‘SIP/100-00000488’

Is this a stock FreePBX install?
Something is not right as you go from [email protected]:13 to [email protected]:20 and that to me indicates something bad with your dialplan.

Very interesting! It is stock so far as I have not manually modified it. I use the FreePBX control panel to make any changes, and do not edit scripts myself, as advised against.

Where should I look? I have three did’s and two voicepulse trunks supporting 4 concurrent calls to the outside world. Could something have become corrupted?

I think maybe I’ll restore a full backup of the system disk I did over a month ago, and then go ahead and do all the updates.

I don’t think I’ve made too many changes, mostly additions to the blacklist should be all I lose, and of course call logs.

thoughts?

What of my config would you like me to post that may illuminate the error?

Thanks again!

Lee