Beta 1.1100.211.63

Just was wondering if I missed something or did something wrong. On all outgoing calls with this build I cant hear the ring back. All calls go through and the other end rings I just don’t hear it. I will eventually if no one picks up start hearing ringing. So I re downloaded stable release and loaded and didn’t have to change anything? I also in (proper stages)ran updates for beta from

any thoughts on something I might be missing ?

Ring back is sent by your carrier as either media or signaling. My guess is your carrier is not sending it. SIp traces and pcap traces would help

Thanks Tony for clarifying that for me. I should have mentioned in my previous post
this is a test machine and I used Google voice if that matters to what your referring to. Only using SIP and the Google voice module. Like I said on previous stable releases from 2.8 to 2.10 i didn’t have to make any changes that i know of.

Yes google voice does not provide ring back. Its a known issue and not something they support.

Ok thanks

I just do what I was told by Josh from digium.

Tony that’s not entirely true. You can make Asterisk generate fake outgoing ringing (simulated ring)

The issue @whiteshadow was talking about is detailed here:

Also it’s been fixed, but we haven’t pushed out FreePBX 2.11 beta 2 yet so you won’t see the ‘fix’

If you look in that bug report I detail how to fix the issue.

Note: This is Google Voice Chan Motif.

@tm10000 Thanks I knew on previous versions i had ringback. I read somewhere you could do that “r” in there but thought i also read against doing such. That worked it had Tt in it now has “Ttr” and the phone now rings.

Yes I agree you can add the r option to generate fake ring but that is really hacky and is so wrong. The issue with that is its not true ringing its asterisk playing a fake ring so you might get a ring or 2 then get a busy tone or a disconnect tone.

This information was very helpful. I recently updated freepbx (running on an RPi) and noticed that I no longer had ring back using chan_motif. In the logs, it shows the trunk as using “tr” option. I went in and modified the trunk as suggested in bug # 6067 and it’s working now.

The odd thing is that I’m running FreePBX 2.11 beta 2.2, which supposedly has the fix applied, but it doesn’t seem to work.