Bandwidth.Com & E.164 Format causing outgoing calls to fail

I’m a rookie making I’m sure a rookie mistake and am looking for some help regarding outboud calling to my SIP trunk.

Iam running Freepbx with 2.6 modules and Asterisk v1.4.24. I obtained my original version from the asterisk site and downloaded the .iso which provided a complete install. Hope that helps with the version I’m using and where it originated from.

I have a SIP trunk from I have successfully gotten inbound calls to work. I dial out and get circuits busy message. I called the techs at and he said he could see where my calls were coming to them but they were not coming in with the + in front of the 11 digits. I tried several things while he was on the line and he could see 10 digits and then 11 digits but as he put it…it wasnt coming over in E.164 format.

In the edit trunk screen Ihave +1NXXNXXXXXX in the Dial rules. I have tried many different permutations of plus sign and no plus sign and just plus sign with various patterns. Nothing works. The current setup gets out to Bandwidth.

I have an outboud route setup. I have tried many different permutations here as well. right now I have 1NXXNXXXXXX IN THE DIAL PATTERNS FIELD. I have tried all types of things in here as well.

What do I do to get the call to go out in the E.164 format? Help PLease!

for your dialpatterns in the TRUNK screen, assuming you allow 10 and 11 digit formats, do the following:


then in the outbound prefix add:

this will get the plus on. If you need international, for your trunks add


Note these are for the trunks, you need to pass the right information in the routes to get there.

Hey P,

You are the man! Your my hero. I knew I was missing one small detail. It worked perfectly.

Thanks a ton!


I noticed you are using and had problems with Outgoing calls…

Ive just started using and having problems with incomming calls…

I think my problem may also be related to e164 formating…

Would you please share your configuration (trunk & inbound) for inorder that i can compare against my config

Thank you