e.164 and Polycom "Received" "Missed" calls list

When I get an incoming call via a trunk, it has a + in the front and this gets recorded like that in the Missed Calls and Received Calls list on the phone, for example “+14155531212”

The trouble is, when you try to simply select the number from either of these lists via the phone gui, it will dial with the + still in front, leading to an error message that looks like this:

[2013-10-09 18:08:07] NOTICE[2168]: chan_sip.c:24133 handle_request_invite: Call from ‘2046’ ( to extension ‘+14155531212’ rejected because extension not found in context ‘from-internal’.

I did research this is a bit, but all the solutions seemed to suggest the need to edit one of the *custom.conf files or call and have them switch to normal 10 digits.

Everything is working for incoming/outgoing calls for some time now so was hoping for an easier fix.

Thanks in advance.

Set the trunk context to:-


ref: /etc/asterisk/extensions.conf

I see that trunk context in the file you referenced, so in my SIP Trunk definition for, in the box for Outgoing Settings - “PEER Details” I added “context=from-pstn-e164-us” at the beginning. The full “PEER Details” now look like this:


Did I do it correctly? I was imagining this would strip off the “+” from incoming phone numbers CID, but they still show up in my phones call lists so basically I can’t say anything has changed.

However, I did have some success. After some more poking around, I changed one of my dial patterns in my Outbound Route for from:

prepend: nothing
prefix: nothing
match pattern: 1NXXNXXXXXX

prepend: nothing
prefix: +
match pattern: 1NXXNXXXXXX

This seems to have resolved the issue for outgoing calls. 11 digit numbers work, with or without the + in front.

My only thought is, did I do everything according to “best practice”.

1 Like

Set your Polycom’s digit map to include (recalling from memory here) R+RR1[2-9]XX[2-9]XXXXXX to remove the +. There’s also a configuration flag to make the phone dial all numbers according to the digit map, not just manually entered ones. This would need to be set so that digit map rules will be applied to your recent calls list.