Bad ringing audio


I have a configuration problem with FreePBX after upgrading to 2.4.0 (we use Trixbox): the ringing audio is distorted.

Most things work correctly after the upgrade. There’s an IVR, and the calling party can dial the extension number. But when the extension is rining, the ring itself is somewhat distorted and/or truncated; in some cases you can’t even hear it for some seconds, then it gets back but again distorted/truncated.

Any idea what can be causing this effect? We tried changing the codec (GSM, ulaw, speex) but to no effect. It didn’t happen on our previous server which was in production for 1 year and we didn’t change anything wrt our VOIP provider (used as inbound trunk).

You have not provided much in the way of details here. So here are some questions… Is this in a VM? is this a hand build or ISO/distro, If so who’s which version, etc. What version of asterisk?

What was the previous version you were running?

What trunks do you have on this box?

What is the load on the box when this is happening (use top)?

Do you have call recording going on, or music on hold using MP3’s, is so what is the call load like? as the more concurrent calls under those conditions will drastically increase the load on the box.

It’s a real server, running trixbox (no VM).

Current version: Trixbox CE 2.6.1, PBXconfig 2.4.0, Asterisk 1.4
Old version: Trixbox home 2.2.4, FreePBX 2.3.0beta2, Asterisk 1.2

I have two trunks: a VOIP provider, which has the bad ringing audio problem; and a standard analog provider through a Zaptel card, with which there is no audio problem with the ringing.

The load of the box at the moment the ring is generated is absolutely 0. This happens with just one call and nothing else running on the box. I have further data, hoping it can help:

  1. There is no ringing problem if an extension makes an outside call, or if an extension calls another extension. The problem with the ringing happens only from an outside call, when the ringing is generated after the user has selected an extension from the IVR menu.
  2. It only happens with the VOIP provider, not with a normal analog call through the Zaptel interface.
  3. We dumped the RTP audio packets generated by the server Then we managed to playback them. We confirmed that the server (Asterisk) does indeed generate a perfect ringing sound. So the sound gets distorted somehow in the way to the VOIP provider. It must be something in the negotiation with the VOIP provider that changed between the two server.
  4. I can switch the old server with the new server at any time, and the behavior is perfectly reproducible. The old server has no problem whatsoever, and the new server does have the bad ringing problem.
  5. We compared the SIP registration packet made by the two servers to the VOIP provider, using wireshark with verbose dump. All the fields are identical. The only difference is that the old server (the one that works) generates an additional field called “opaque value” with an empy value; the registration packet generated by the new server doesn’t have this additional field. It didn’t look suspect to me…
  6. We hear the bad ringing with both GSM and uLaw. Both codecs, when used with the old server, do not generate the bad ringing.
  7. We tried another VOIP provider, and we have the same problem. But our primary VOIP provider is a major one in Italy (EuteliaVoip), so I wouldn’t be surprised if the second one is just a retail reseller of the same product at wholesale, or something like that.

I found another report of this problem with Google:
and it was made within the forum of the same italian VOIP provider (EuteliaVoip).

I believe this has something to do with the VOIP provider, but I wouldn’t know how to report this. In fact, there has to be something with Asterisk after all, since switching servers make the problem appear and disappear.

Quickly I’d say you have one of two problems.

1.Incorrectly set firewall/port forwarding issues and/or sip_nat setup issues. (Which would effect audio, but normally noticed as one way audio and or audio issues after a minute or three based on port forwarding packet timeout values).
2. with the voip provider and the route that the traffic takes. As audio quality issues are easily effected by any delay in packet delivery, etc. Are you sure you are NOT maxing out your internet pipe in some way? (What type of internet connection do you have symmetric (T1, SDSL, etc) or asymmetric (Cable/DSL/ADSL)? Does a traceroute to the destination take the same path on each box? Also what some people don’t realize is properly configured DNS can effect things so check all network settings from routing to DNS to make sure they are identical between systems.

I got the same problem, MOH is cutted, stops and restart. I have a remote dedicated server all the rest works fine even the ivr announce. Any idea? It seems that Asterisk is reading badly the MOH file. Can be a codec problem? where I can change it?

I had this problem with one of my installations; muddled ringing heard by the caller on a voip trunk when calling the customer’s toll-free number. I have the voip carrier port the number to a different RESPORG and that solved the problem.