Backup/restore problems

I’m trying to backup a working prototype system and move it to a new box to make sure I have a disaster recovery plan in place.

My original box is an Atom-based machine running Stable-5.211.65/Release Date-2014/FreePBX 2.11, Linux 6.5/Asterisk 1.8 or 11 (using 11).

My target box is an Intel NUC running the same release of FreePBX.

I did a full backup of the Atom box to an FTP site. I then restored this backup to the Intel NUC box and the restore seems to run without a problem. But when I reboot the Intel NUC box, I get the message: “vqplus module is not licensed” and the phones won’t attach to the Intel NUC. When I look at the asterisk console (asterisk -r) I get quite a stream of warnings (is there a way to capture/post those?)

Any ideas what I’m doing wrong here? I did a full backup, and I checked everything for the restore.

TIA for any help.

Any ideas or tips on this?

It might be unrealistic to expect that backing up from an Atom-based machine and restoring on an Intel NUC based system would be totally successful. If I were designing a disaster recovery scenario I would use IDENTICAL hardware to avoid any problems introduced be potential incompatibilities of different hardware platforms.

Is there any official guidance on this? I read the guide on backups/restores but didn’t find anything that indicated any hardware-specific data was being backed up.

It seems like it should work from what I’ve read in the guide.

If you’re using the backup module the only real gotcha is you need to make sure both FreePBX versions are the same. You can’t restore a 2.10 to 2.11 etc. You also need to make sure both systems have the same modules installed. Some folks backup /var/www

I believe the vqplus is the virtual queue plus paid module. Go to module admin to remove if you don’t own it. Also go to asterisk sip settings and make sure your ip info is correct for the new box.

Hey all. I have had similar problems on this one and looking for ways around it. I am simply trying to have a second duplicate cloud machine for redundancy in case the prime machine goes down. They are on different cloud based providers and located in different cities (again to minimise risk of failover). The plan is to keep IP addresses different but just enable the trunks on the second machine if the first one fails. It is mainly for IVR but I probably install a “line 2” on the phones as well that points to the second machine down the track.

So here is what I did with some lessons learnt for anyone trying it (as well as some questions for where I am still stuck).

  1. Use FreePBX 14.0.1rc1.11 on both machines. I know it is still in development but as some feedback it works a treat (I have no issues with my prime machine at all) !
    1b. I also upgraded all modules on both machines before backup.
  2. Did a default backup on Machine1 (just mysql and Asterisk db) and restored it on the other.
  3. It read in fine and almost all came across ok except:
    3a. The dashboard refresh started taking 5 times longer to do.
    3b. The extensions were missing voicemail Optional Destinations. I fixed this by writing over the extensions again using a csv from the first machine from bulk handler. Worked brilliantly so thankyou to whomever maintains this, it is a great tool.
    3c. Started getting issues with the dashboard “Freepbx Statistics” - it was a blank graph. Fixed this by noticing that my Asterisk Manager password (in Advanced Settings) was now the same as the first machine so I looked up freepbx.conf and put that back in. Issue fixed. Although dashboard still very slow on refresh.
    3d. Changed the IP address in Sip Settings back to what it should be for the second machine. Although now I notice that Machine2 cannot detect its own External Address (I am hoping someone knows why ? - so I put it in manually)
    3e. I cannot do Module Updates anymore (I could before the restore). I get “Warning: Cannot connect to online repository(s) (, Online modules are not available.”

This is where I am stuck. For this I have read a lot of posts here and tried:

fwconsole chown (does its thing ok but doesnt fix the issue)
amportal a ma refreshsignatures (says it “Cant Reach Online Server” so did nothing)
amportal a ma update framework (came back with "Retrived Module XML was Empty)
fwconsole moduleadmin upgradeall (says it is up to date)
rebooted the whole machine. Didnt help.

So my machine still cannot resolve its own IP address nor can I update any modules and the dashboard still very very slow on refreshing.

Greatly appreciate any suggestions. The main reason I am doing this is to get the IVR which would take me a couple days to setup again on Machine2. What seems to be a fair easier approach is if Bulk Handler could just write out IVR settings (maybe also Ring Groups and Trunks) and then the whole thing could be setup without a “restore” which complicates things by overwriting passwords, IP addresses and all the other things Restore wants to do. Life would be easy !!! Or maybe have finer granularity on what is backed up and restored would be the other way I suppose where you could just ask it to backup, extensions, trunks, IVR and leave all the other stuff out.

I also am considering starting again with a fresh install of Machine2 and trying to just reading the IVR in via SQL. I noticed that the mysql-2.sql file had everything I needed in there. I cut out just the bits I needed (e.g. the CREATE TABLE & INSERT INTO commands) for the IVR, now if someone could just tell me how to run this sql on mysql then I will be good to go as I havent found this on here yet but will start looking if there is no quick answer to the above.

Sorry for the long post. It is my first one after around 8 months of PBXing (and lurking to learn on here)! So thanks to the Freepbx community - I tried out a lot of PBX’s and this one is definitely the best :slight_smile:

Disregard the above. I figured out an SQL way to read in data manually in case anyone is interested. Here it is: