Backup/Restore from v13 to v14 Failure

I have installed FreePBX 14.0.1alpha34.

Prior to doing that, I used the Backup & Restore module, to backup my FreePBX configuration.

When I attempted to restore that backup to 14.0.1alpha34, it gives me an error that the ‘calendar_id’ is missing.

Now I’m stuck with the ‘Apply Config’ button in a permanent status where I cannot apply this change (or any future changes of any sort) and I cannot revert back what I’ve done.

In short, the system appears to be hosed. Is there any way to make v14 more forgiving when importing backups from prior versions?

Thank you in advance.

For reference, this is the full copy of the error message:

exit: 1
PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'calendar_id' in 'field list' in file /var/www/html/admin/modules/findmefollow/Findmefollow.class.php on line 714
Stack trace:
  1. PDOException->() /var/www/html/admin/modules/findmefollow/Findmefollow.class.php:714
  2. PDOStatement->execute() /var/www/html/admin/modules/findmefollow/Findmefollow.class.php:714
  3. FreePBX\modules\Findmefollow->get() /var/www/html/admin/modules/findmefollow/
  4. findmefollow_get() /var/www/html/admin/modules/findmefollow/
  5. findmefollow_getdestinfo() /var/www/html/admin/libraries/usage_registry.functions.php:300
  6. framework_identify_destinations() /var/www/html/admin/libraries/usage_registry.functions.php:351
  7. framework_list_problem_destinations() /var/lib/asterisk/bin/retrieve_conf:817

fwconsole ma install findmefollow

@tm1000 thank you so much for the extremely quick reply!

I logged-in to the console and ran that install, it solved the problem!

1 Like

Turns out, that did indeed allow the config to be applied. However, none of my extensions would login.

I went to look at the extensions and every one of them causes an error. I can delete / recreate an extension and it will work; however, the Backup/Restore does not work.

EDIT: I re-attempted another fresh Restore and ran into the same problem the second time as well.

Here is a screenshot of the error I’m seeing, if you need more information please let me know.

Thanks open a bug report if you can :slight_smile:

FreePBX is not setup to allow backup and restore between major versions. This has never worked.

From what I’ve seen here, backup and restore has major problems between most versions. It makes sense, since the database gets backed up and the database is one of the commonly changed objects when there are even minor version number changes.