Autoprovision Yealink phones with 2012 DHCP server?


(Sentinel) #1

I am trying to provision over 20 phones which right now I can point to my pbx manually and they work. I used option 66 with DHCP and they do not provison. I did read you can use option 43 but wasn’t sure how you configure the DHCP server with option 43. I tried to add the value of the pbx with no luck. Any ideas?


#2

Are you using TFTP or HTTP. I have a similar setup with option 66 which using HTTP without issue.


(Sentinel) #3

I tried http with option 66 and phone just says no service on the T22P phone but seems to work on the T48P


#4

All of ours are T46’s and T41/42’s. Does the T22 pull an IP address? Also, you may need to research the firmware load as it may or may not have a restriction on which method it requires (i.e. HTTP or TFTP) to pull the config.


(Sentinel) #5

Okay. Got further. If I got into the Auto provision of the phone and type in the tfp:\ipaddr, then the provisioning works. Is there a way to get that automatically?


#6

DHCP option 66 should work. The format of the option changes slightly depending on if you use HTTP or TFTP and you may need to specify the port depending on your FreePBX release. You can do a web search for the format. I have personally found HTTP to be the better method, TFTP seems to be less supported depending on your firewall.


(Sentinel) #7

I am able to get them to provision now. The issue I have is, the username/password do not get set and I have to manually set those for the phones. Where would I set that in DHCP?


(Mark Moore) #8

URLs can include username and password. The format is https://username:password@pbx.example.com