Automate changing Progress to Ringing in extensions_additional.conf

We are in the process of configuring FreePBX to link two big name communication platforms together. We have things working but we have an issue with one of the systems not liking 183 progress and demands 180 ringing. We can fix this by manually changing all lines in “extensions_additional.conf” that have Progress to Ringing. Works great, but every time we add a FreePBX user and save it, the whole file changes back to Progress. How can we make Ringing the default?
We tried “Inband Progress” on the trunk–>pjsip–>Advanced and other settings but nothing really seemed to help.

Put it in extensions_override.conf that will override any context you put in there permanently.

Thanks for the reply!
I did find that as an option while searching. I tried to take the sections in “extensions_additional.conf”, make the change for Ringing, and then paste the sections in “extensions_override_freepbx.conf” and rebooted. It didn’t work. I made a change to an extension and saved & applied config too.
How should this change be written to “extensions_override_freepbx.conf”?

The entire context needs to be in the override, then it will use what’s in override ahead of what is in additional. Other than that, it is normal asterisk dialplan.

Yes, that’s what I did but I didn’t go far enough in testing.
I was wrong! It DID work! When I look at sngrep and make a call, it does send 180 Ringing. I was expecting the extensions_additional.conf to have the changes applied in the override file after a save and apply. FreePBX still writes its defaults to extensions_additional.conf but will follow the override file when a call is made. Going to test a bit more.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.