Audio Issues with FreePBX 15 running on Ubuntu

freepbx-15
Tags: #<Tag:0x00007f702a4f38e0>

(Haduran) #1

I am new on implementing the FreePBX, however I am working to implementing the PBX on the cloud, to be more expecific, this PBX was created on google cloud. I was able to use a market-plase image, also I did the NAT configuration.

For that reason I enabled the ports 5060, 5061 also enabled the RTP ports from 10000 to 20000, on the server and also on the instance of the VM.

I set two devices “softphones” out of the LAN, these extentions are able to register and able to make calls and recieved calls, however the audio doesn’t work.

We can not hear anyting on both devices, I know that when we using NAT, we going to have some issues, but if I already enabled the ports, set also a stun server, confirm that both applications “softphones” using the same codecs that has been set on the PBX.

Why we have this issue with the audio ?

I am using pjsip extentions.

Could any one help me with this ?


(Matt Brooks) #2

Well, there are many reasons for why audio wouldn’t be passing between two softphones. The main thing I can suggest is to checkout the FreePBX NAT guide to make sure there isn’t a configuration option that you’ve missed: https://wiki.freepbx.org/display/FPG/NAT+Configuration+FreePBX+12

If that doesn’t fix the issue the next thing I would look at is the SIP packets that are being sent to the Asterisk service. You can do this by enabling PJSIP debug:

pjsip set logger on
pjsip set debug on

This does require you to learn how the SIP and RTP protocols work. However, the main thing you want to look at in the debug logs is that SIP packets are telling each request to go to the right service. I.E registration is pointing to the public IP and not the private one, RTP is being told to go to the public IP and not the private one, etc. Basically, look for private IPs and it’s probably bad.