Audio cuts out after 14 seconds

FreePBX Distro
asterisk 13.14.0

New system install, first time using pjsip (not sure if thats related to the issue).

Calls connect fine but after 14 seconds audio both ways got to hell. Did a wireshark and I see on the RTP analysis Detla (ms) suddenly goes from about a consistent 29-30ms to 4000 and then drops to 0. Jitter goes from 1.50ms to 258ms then slowly starts to drop down to 30ms until again delta hits 4000+ms.

Is this a mis-configuration on the phone system or a network issue. I find it odd that it consistently happens at the 14 second mark (you can hear it go on the call).

Sounds like a nat/firewall issue. Make sure you have any sip alg disabled and the correct udp ports for media forwarded through your router

1 Like

yeah, been all through that. going to be onsite tomorrow and make some network changes.

Onsite today and have witnessed several instances where the entire network goes to hell for a short period. Running a continuous ping to the gateway and every now and then I get alternating packet drops and 4000ms returns. Then after about 30 seconds it goes back to normal. So there seems to be some random network issue locally that is causing the call quality issue.

I have yet to track it down…

May be a loop back. If switches are suppressing it, they will kill the port and then if they have a back off timer, the port may be coming back up… causing issues and being killed again

Good luck, those issues are never fun to try and find

Thanks Jameson, was thinking something similar. In the end the existing switch was the issue. took it out of the network and problems gone. I’m moving the data closet anyway so I’ll be upgrading the switch. Narrowed down the trigger was any time an employee tried to access a document directly from gmail or google docs… Open it, print it etc.

in any event, problem solved. Thanks everyone